Trouble installing Nvidia drivers

I’m having trouble installing Nvidia drivers for my notebook. It’s an Asus with a GeForce GT 635M. I have it configured to dual boot along with Windows 10. I tried doing this before with Kali but had no luck either. After trying Parrot I really liked the OS but I can’t use it for my everyday tasks if I can’t get the video card to work.

I tried downloading the .run file fom Nivida’s site and after a lot of hassle with nouveau, the kernel version and other stuff that I somehow managed to solve, I got the driver installed but when I rebooted a blank screen was all that showed. I Ctrl+Alt-F1 for tty1, deleted the driver and reinstalled it via apt-get install nvidia-driver.

After installing it again the NVIDIA X Server Settings icon was visible in System -> Administration, and when running it it displayed the message “You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root)…”. I did that and it said
“WARNING: Unable to locate/open X configuration file.
New X configuration file written to ‘/etc/X11/xorg.conf’”

After rebooting I get the blank screen again and no GUI, so I had to delete the xorg.conf file from etc/X11 to get it back. I thought maybe the old driver was making trouble with the new driver or something like that so I did a fresh install of the OS and installed the driver again with apt-get install nvidia-driver and after that the nvidia-xconfig but no luck…

Please somebody help me install this damn driver!! I saw Linus Torvarlds on youtube saying how much problems were with Nvidia and their drivers (“Nvidia, fu** you!” were his words X). Is this the kind of trouble that he meant??)

Any help would be greatly appreciated :slight_smile:

What version of Parrot are you running? Parrot 4.2.2

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Yes Linus is a funny chap.

Like he says, a reinstall might be your easiest option at this point.

These might help:
https://docs.parrotsec.org/doku.php/nvidia-drivers
https://docs.parrotsec.org/doku.php/nvidia-driver-install-updated

Thanks for the reply. I did a reinstall of the OS and followed the steps from the first link (I had already tried that method with no success). I did everything from the updated version and at the end when doing optirun glxinfo | grep OpenGL, it spits out this:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 635M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.87
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.87
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

but when entering to the NVIDIA X Server Settings it keeps asking me to do nvidia-xconfig from terminal as root, and I keep getting nvidia-xconfig: command not found.

Is there anything else missing ??

Since deleting the xorg.conf file in /etc/X11 brings back the GUI, maybe it’s configuring something in that file ??
Here are the details of the xorg.conf file:

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 390.25 (buildd@debian) Wed Mar 7 00:58:28 UTC 2018

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
EndSubSection
EndSection

At the bottom of the first link you will see a section about xorg.conf
Use: /etc/X11/xorg.conf.d/20-nvidia.conf not /etc/X11/xorg.conf

I tried that as well. Only problem is that /etc/X11/xorg.conf.d doesn’t exists. :cry:

Yeah you can create it

mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

I did that as well on a fresh installation because I had tried a lot of other stuff but with the same result, and again I’m left with no GUI and with tty1 only this thime I didn’t had to Ctrl+Alt+F1.

Maybe the driver is installed but the OS isn’t really using it… I did
lspci -vnnn | perl -lne ‘print if /^\d+:.+([\S+:\S+])/’ | grep VGA
and got this as result

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 635M] [10de:0de3] (rev ff) (prog-if ff)

Which means I guess that the system is using the Intel chip and not the Nvidia chip.

When doing nvidia-settings I get

ERROR: NVIDIA driver is not loaded
ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
ERROR: Error querying connected displays on GPU 0 (Missing Extension).
Gtk-Message: 15:03:28.561: GtkDialog mapped without a transient parent. This is discouraged.

Nvidia sure did make it hard for people to install their drivers on linux.

You might need some additional info in conf.
This arch document gives a bit more detail https://wiki.archlinux.org/index.php/NVIDIA

The nvidia-xconfig is in the repo, but its deprecated. You could install it and see what config it produces.

The problem it seems is that after installing the drivers, rebooting, getting tty1 and checking Xorg.0.log, the nvidia driver (module) wasn’t beeing loaded. I checked in several forums and found someone else with a similar problem and he wrote that installing the drivers with
sudo apt-get install nvidia-driver bumblebee-nvidia
somehow doesn’t add the driver file nvidia_drv.so* in /usr/lib/xorg/modules/drivers/

I checked the directory and indeed there is no nvidia driver file, only intel driver file.

He wrote that he installed everything again with pacman and the installation worked and the file was there after the installation finished. I tried doing this but I haven’t figured out exactly how to use pacman yet, or how to maybe manually add the nvidia driver file to the directory. Please, a little help!! I think that this is the reason why my graphics card isn’t working.

pacman is a package manager for arch, so it wont help.

This is odd, mine works and i never had to mess about with these configs. Once the nvidia drivers are installed, and after a reboot nvidia-settings should open. You should only have to mess with xorg if you are using an old card.

OK, so after a fresh install (again) and only doing sudo apt-get install nvidia-driver, I made the hmdi video work with a Sony TV, and nvidia-settings seems to work, recognize the video card and use the driver. I used the following xorg configuration

Section “Module”
Load “modesetting”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “1:0:0”
Option “AllowEmptyInitialConfiguration”
EndSection

I got the configuration from https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

Unfortunately there is no hdmi audio (“aplay -l” doesn’t show the device at all) and the notebooks display doesn’t work either. After disconnecting the TV and using the notebooks display I get a blank screen so this configuration only works for one monitor and that monitor has to be my TV…:sob:

nvidia-settings can generate a config for you, look at the difference in that one.

https://www.x.org/archive/X11R6.8.0/doc/xorg.conf.5.html this is the man page, should help with configuration.