Troubles installing Nvidia drivers and Bumblebee

Briefly describe your issue below:
Hello,

So I’m a new user, (that’s maybe the cause of the error…) and I tried to install the Nvidia drivers with the help of this link : https://docs.parrotlinux.org/info/gpu-drivers/

I followed the step, and all seems to be good until the installation of Bumblebee and Primus.
At this step, my computer started making some huge noise (probably because the graphic card started) , and the troubles begun. When it comes to the optirun line, here’s the response :
[ 228.313710] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Problem parsing the config file[ 228.313749] [ERROR]Aborting because fallback start is disabled.

At first I wasn’t paying attention (that’s dumb) and I rebooted. At the start, I got the message below the post, and could not start Parrot in any way. I had to get to the recovery mode to delete Bumblebee and Optimus , rebooted, and it worked as in the beginning. I retried with the .run file on nvidia’s website, retried with the original link and the same thing occurred. I tried googling the first error message (the optirun one), and followed another link that told me to change a value in the xorg.conf.nvidia file, I rebooted, that did not help.
I searched on multiple forum, but did not found anything that worked.

I would appreciate any suggestion, because I need to work with graphic-vacuum software soon.
Thanks for reading and taking the time to respond me, and again please be kind with me, or I’ll call my mom.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
I tried on an Asus laptop, with a GTX 1050 ti, and the latest build of Parrotsec Mate edition (4.8).

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard

Configured to multiboot with other systems? (yes / no)
yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Picture of the screen with the start error :

https://framapic.org/random?i=zsv5pl58ldwo/jxg9rablSCz2

Welcome to the ParrotOS Community :hugs:
Similar Issue
ACPI BIOS Error (bug) - Parrot os(Same Issue)

Thanks for the response !
So there isn’t any solution yet ?
Will I have to work on …ugh…Windows ?

as mentioned in the Debian Faq - (3.1)
Under most circumstances it is advise a stable version, since if you use
other versions then you can almost expect to run into problems, and
you are almost expected to be able to cope with them by yourself.

maybe the problem you are facing could be due to Debian as Parrot OS is Rolling distribution which means it works on Debian Testing

maybe you can try out some other distribution which is based on Debian Stable

also for @landomix

1 Like

Thank you very much. I already tried the “bumblebee” mentioned here, and I already installed the missing firmware, but I’m still not able to boot withou ACPI off, and also if I boot with ACPI off my laptop still freeze while shutting down (I have to press the power button, and I think this could damage my laptop).
I already tried also Kali linux, Ubuntu, and Lubuntu, but no one worked, all of them just crashed somewhere while installing or had the same problems that I’m having with Parrot.

Could it be a problem with linux kernel? If so, what should I do?
(I don’t know because I’m quite new with linux, I’m just tryng to be helpful to understand my problem)

As told by G.W. Haywood on Mail-Archive
“I wonder if the issue is in the BIOS (firmware) in your computer, not
in a Debian package. In that case you might not need to report it at
all, because it might already have been fixed, or your BIOS might be
obsolete. UEFI has been relacing BIOS almost everywhere, for several
years, so if it is the latest version, I’d almost expect any BIOS to
be obsolete and therefore not fixable.”

it could be a issue with your BIOS,could you provide some details about your BIOS

Unless you are going to work with a specific software that you know is available for linux…most probably.

I know that they are available on linux, but without graphic card it will be very slow…

Did you find the solution to your problem?
Im having a similar issue, but the system hang in the middle of the session