Unable run properly parrot-upgrade

parrot-upgrade can’t connect to repo

Parrot 5.0
5.16.0-12parrot1-amd64

The full output:

I run sudo apt update and then sudo parrot-upgrade, but some packages were not updated, so i tried change the mirror but no one worked.

Hi. Are you behind a (company, school, etc.) firewall? Try changing https://sft.if.usp.br/parrot/ to http://sft.if.usp.br/parrot/ (http instead of https).

If needed, try the mirror http://parrot.mirror.garr.it/mirrors/parrot

Sounds like you may have a corrupt/broken package, you could try

From terminal run sudo apt-get update then run sudo apt -get update --fix-missing
then try again with sudo parrot-upgrade

No, i am connected from home. And i already try change http instead https.
I tried change the mirror and still not working.

It works whit some packages, but not whit all.
This is the packages not updated:
hwloc/parrot-backports 2.7.1-1~bpo11+1 amd64 [upgradable from: 2.7.0-2~bpo11+1]
libhwloc-plugins/parrot-backports 2.7.1-1~bpo11+1 amd64 [upgradable from: 2.7.0-2~bpo11+1]
libhwloc15/parrot-backports 2.7.1-1~bpo11+1 amd64 [upgradable from: 2.7.0-2~bpo11+1]
yara/parrot-backports 4.2.0-3~bpo11+1 amd64 [upgradable from: 4.1.3-1~bpo11+1]

Hi Sebastian,
have you tried updating your souces.list file as stated here Mirrors list - Parrot Documentation? Anyway, if it can be useful, here parrot.list - Pastebin.com you find the default content of my file /etc/app/sources.d/parrot.list, where you can also find some popular mirrors.
P.S. To upgrade Parrot I just need to use parrot-upgrade

So I tried all the solutions I found and nothing worked, so I disabled the deb Index of /parrot/ parrot-backports main contrib non-free repo and i changed to the direct core server and it worked. My question is: Is it a bad idea to disable this repo?
Here’s how my sources.list file looks like: ## This file provides the default APT repositories for Parrot Security## These - Pastebin.com

Hi Sebastian,
backports provide new versions of some packages without waiting for the release of the new o.s. version. I would leave uncommented (deleting the characters #) the last line of the Backports section in your file /etc/apt/sources.list.d/parrot.list

seems to me like a network or date/time settings problem ?

It’s more like specific mirror is having problem. There are community mirrors that Parrot team doesn’t have any access so we can’t fix them. Well in this case, maybe user can blame our redirector didn’t do the job well.