Unable to anonimise using tor

I have been trying to run firefox through proxychains but tor does not seem to do anything as my true IP is being detected. I am using Parrot 4.5 on a VM. Yes, I did service tor start and it should be running and listening for 9050. There should be no problem with proxychains.conf since dynamic chains is enabled and strict chains disabled. How can I pin down this problem?

I know that Parrot OS has its own built-in feature “anonsurf” wich is working well, but I don’t quite know how it works. Is it utilising tor?

I have never used proxychains so i cant really help with that configuration.

But i can say anonsurf uses iptables rules to force all outbound connections through tor. So when you start anonsurf, all of your network connections will go through tor, any that cant will be dropped. You can read the script here: https://nest.parrotsec.org/security-tools/anonsurf/blob/master/anonsurf.sh if you are interested.

If you only want firefox to use tor, you could just use firefox’s built in proxy configuration settings. Once you have started tor, just go to firefox preferences and scroll down to network proxy. Select manual configuration, then in SOCKS put ‘’ and port ‘9050’ (Might want to proxy DNS as well). Click OK and bobs your uncle.

Best way to hide yourself is to use a VPN server. For more infos please join #parrotsec on irc.freenode.net