Unable to Create GVM (~OpenVAS~) User

OS version: Parrot 4.10 Security Mate
Kernel version: Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux
Installer: Calamares installer
Packages up-to-date: Yes, via sudo parrot-upgrade

I’ve spent a week researching via Google trying to get past this issue on a laptop install, and tonight tried it on a Virtual Box install and have the same issue.

Steps taken:

  1. sudo apt remove postgresql-12 postgresql-client-12
  2. sudo pluma /etc/redis/redis.conf
    And uncommented the following lines:
    unixsocket /var/run/redis/redis.sock
    unixsocketperm 700

Using gvm-check-setup to check for steps…

  1. sudo runuser -u _gvm – gvm-manage-certs -a -f
  2. sudo runuser -u _gvm – greenbone-nvt-sync
  3. (sudo runuser -u _gvm – greenbone-feed-sync --type SCAP) did not work so used:
    sudo runuser -u _gvm – greenbone-scapdata-sync --refresh
  4. sudo runuser -u _gvm – greenbone-feed-sync --type CERT
  5. sudo runuser -u postgres – /usr/share/gvm/create-postgresql-database
  6. sudo runuser -u _gvm – gvmd --create-user=admin --password=admin
    sudo runuser -u _gvm – gvmd --create-user=admin --new-password=admin

Step (8) is where it fails. There is no output after step (8) and running

  • sudo runuser -u _gvm – gvmd --get-users

shows no users were created. I have tried other users and other passwords.

BTW: There is an underscore before gvm (_gvm) and two dashes before gvmd (-- gvmd), but it is rendered in HTML as a single dash.

gvm-check-setup continues to not be able to get past:

ERROR: No users found. You need to create at least one user to log in.
    FIX: create a user by running 'sudo runuser -u _gvm -- gvmd --create-user=<name> --password=<password>'
 ERROR: Your GVM-20.8.0 installation is not yet complete!

I’m wondering if there is something in postgresql-13 I need to do after step (7)? I saw a comment from a developer on a post from several months ago about issues with gvm.

I finally got it past the gvm-check-setup on the virtual machine. I forgot to edit and change

  • sudo pluma /etc/postgresql/13/main/postgresql.conf
    port = 5432

then run

  • sudo systemctl restart postgresql

But I think I did something to create the admin user after that which I didn’t document. Something like

  • sudo runuser -u _gvm – gvmd --create-user=admin

to generate a password. Maybe dropped the gvmd database first. Trying to follow/recreate the steps on my laptop. BTW: Accessing the Greenbone Security Assistant with extensions disabled appears to have fixed some stuff. I’m new and just starting to learn the system.

As far as my laptop was concerned, the final fix was to change permissions of some files from root to _gvm:

  1. cd /var/lib/openvas
  2. chown _gvm:_gvm *

Now I can play around and see if it works.

So apparently, Greenbone has taken over the open source project (OpenVAS) and the latest gvm packages for Debian do not work correctly on Parrot (or Kali). They no longer offer a Community Edition iso as of earlier this year, and files like reports and filters do not work unless you manage to migrate certain directories and files from older editions of gvm (11 => 20.x) or take the time to build everything from source using long complicated directions filled with pitfalls and errors. There is only a trial version iso from Greenbone.



Sorry we’ve been busying 4.11 beta preparing. We knew there are serious problems with GVM but nobodies checked the news from GVM. I am forwarding your information to our team. Hopefully we can do something.

1 Like

I noticed there were a lot of updates for Parrot Security when I launched it tonight on my Virtual Box install, including a few for OpenVAS and Greenbone.

It’s finally working! You guys rock! Please send my appreciation to the team! Thank you! :smile: :joy: :clap:

Awesome! :star_struck:

But how can you make it work? We are having problems with this version: can’t create scan and so on. In fact, we are going to remove it from preinstalled tools. It will be provided for cloud edition only. The sec edition will focus on manual pentesting more than auditing.

I got it working last night on a Virtual Box guest. It was able to (slowly) scan a Metasploitable2 guest and return a report with all the found vulnerabilities. This was not working before the updates I installed last night.

The Target port list was available, the OpenVAS scanner was available (only the CVE scan was available before), once the scan was started it took ~20 minutes and showed the progress, and finally when completed it showed the full report of vulnerabilities it found on the target.

Later today I’ll be working to try getting it working on 2 laptops and a VMware guest. I’ll report back!

Thank you for the info. I’m installing it inside VM and see how it goes.

I’ve gotten it working now in a VMware guest. But not on my 2 laptops: they still can’t get the Port List when selecting a target or the OpenVAS Default Scanner when creating a task, saying that some long hexadecimal config could not be found.

Not sure if this makes a difference, but I noticed on my Virtual Box and VMware guests they are using the repository:

But my laptops were using:

I switched my laptops to the first repository, but no new updates were found.

A screenshot of my VMware guest’s successful scan…

That is the smae problem on my PC and my VM. At least from 4.11 beta testing, we don’t have the problem of postgresql version error

I reinstalled all OpenVAS and Greenbone packages using Synaptic on my laptop and restarted. It still wouldn’t show the port list or default scanner. But then I saw in Parrot Menu => System Services => OpenVas - Greenbone that there was a new menu choice of “Start new installation”. I chose that and allowed the resulting terminal to do some things.

Now it’s working on this laptop running Parrot (natively)! The port list and default scanner were there and I’m scanning Metasploitable2 running in a local VMware guest. Ha!

Screenshots of the Port Lists and OpenVAS Default Scanner from one of my laptop’s:

It’s now working on my other laptop after running “Start new installation”.

My Windows 10 desktop blocked scanning, probably due to it’s firewall, but it’s scanning my router now for vulnerabilities.

Turned out this is the error during first setup.

That step (#5 in my original post) didn’t work for my Virtual Box guest for some reason (but did for the other 3 Parrot installs: VMware 14 and 2 laptops). I searched around and found this command does the same thing successfully:

  • sudo runuser -u _gvm – greenbone-scapdata-sync --refresh

FWIW: I installed Kali 32-bit on a very old Atom processor netbook last week (after a lot of workarounds). Last night I was able to install OpenVAS/Greenbone on it as well with just a little hassle.

Thank you for your solution. Unfortunately i ran the sudo gvm-setup again and i got extremely slow internet connection and i interrupted the setup. Now i’m having different error. I’m running the setup script again and i’m having slow connection again.
This problem is killing me.

OH finally i can make it work by sudo gvm-setup again. The lesson is sudo gvm-check-setup until it works.

1 Like


Oops, sorry I wasn’t clearer in my first post. Yeah, I ran gvm-check-setup several times, doing the requested (fix) steps until I hit a road block (step #8). Then I had to do a few extra things to get it working correctly once gvm-check-setup said everything was setup.