Unable to launch menu items

Briefly describe your issue below:
I yesterday updated my parrot snd after that update, any script/program in menu that depends on konsole doesn’t open l. It dhows a error dialog box with “could not find the program ‘konsole’”

Also im completely unable to access parrot sites on normal network unless i use a vpn

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Operating System: Parrot GNU/Linux 4.9
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.70.0
Qt Version: 5.12.5
Kernel Version: 5.6.0-2parrot1-amd64
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-5005U CPU @ 2.00GHz
Memory: 7.8 GiB of RAM

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK

Configured to multiboot with other systems? (yes / no)
Yes with windows 10

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

I need more information:

  1. which program did you try to run?
  2. did you try run command from terminal?
  3. did you verify the konsole (kde termmial) is on your system?
    If this bug is from the menu i can apply a patch and release it asap but i need more information
1 Like

Konsole is installed in os in able to use konsole using shortcut and by directly clicking on it from the menu. Im also able to launch programs using konsole like if i want to launch nmap i can do so by typing nmap when i have opened console but if i try to launch the same program from the menu entry, it doesn’t wnd show the above error “unable to find konsole” it happens with all the menu entries that rely on konsole
I’m attaching a video link(Gdrive)

I stumbled upon here

Sorry that problem is from KDE side and it is confirmed by the KDE bug tracker. The only thing we can do is wait for their patch.

1 Like

Well then got to wait untill they push new update thanks for help

I just noticed that the konsole problem is just for konsole but it effects other terminals also i have multiple terminals installed on my parrot installation. I thought, lets change the default one and then 1st i tried hyper it said hyper not found then i tried mate terminal again the same error byobu, retro term also. Is this error somewhere in menu entries itself?

when will the problem be solved? KDE already fixed the problem

1 Like

Exactly what I’m waiting for too

when i look at the properties of the shortcuts for the metasploit framework, they are set to menuexec whatever_msf. when i run the menuexec script without arguments, there seem to be options for -g groups -u user. might these effect menuexec’s ability to attach to konsole? Also after changing my default term emulator from konsole to xterm then back to konsole, i got “found in path but no permissions” error.(which is weird cuz konsole is set rwxr x rx ) i know KDE is an unwieldy behemoth but this has me a bit stumped… and if i want msf i pop a shell and THEN get to work, rather than point and click, so it doesn’t hurt me a bit, but i would like everybody to be happy with the distro. i will load 4.10 in a virtul machine and mess with different menuexec options along with msfpc and see what i get…

1 Like

No. This is a bug of KDE which find binary from PATH. There is 1 member tried changing Terminal from konsole to terminator and it didn’t work too.

1 Like

Why is the administration not responding when there will be an update ??? when?? or do we not wait for it ??

This issue will be fixed when kde push kde framework version 5.71.0 to stable release currently it is in unstable so got to wait for some time.


Funciona!

I wonder when will debian update the kde framework package from 5.70 to the latest one. Come on debian it’s more than a month.