Unable to mount exfat/android after latest update {SOLVED}

The latest rolling update appears to have created an issue with mounting devices.

i’ve tried mount both an SDcard,and an android device,thus far,neither of them mount.
both come back with different error messages,and both worked fine prior to the latest rolling update…

Parrot Home MATE ISO
Debian standard install
multiboot/ NO
hp 14-ac159nr
https://support.hp.com/ca-en/document/c04852768#AbT0

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

A couple questions:

  1. You had no problems mounting the same exact devices prior to update?

  2. Did you make any changes to that storage (like changing disk format) on storage you are trying to mount?

  3. What is the process you use to attempt to mount the drives?

Immediately after attempting to mount the drive you are having problems with run:

sudo dmesg | tail -25

This should get us more detailed error messages to get clues on the error.

Then google that error and you should be able find resources to fix it.

If you continue having trouble share the last 25 lines from dmesg command segment here in a reply so everyone can see the details of the errors

(NOTE: if you do share, please keep log sharing to short 25 line segments (or less) to keep the forum clean).

1.No,everything worked fine prior to the update.

2.I changed nothing,i simply ran (sudo parrot-upgrade) to check for any available upgrades,and agreed to install once prompted that one was available…

3.I’ll try to answer this in the way i interpret it.
if you mean something else,you’ll have to inform me.

Typically,i would simply navigate to the computer icon,where the available disk and folders are listed,select the device,and mount,as auto-mount is disabled by default.

i would also mount available devices/storage via the shortcut available in the add to panel menu once i discovered it was there.
if your next question is,have you tried to launch it from terminal?
yes,and to no success.

i did read in an online article,(where the latest debian kernel is mentioned as related to this particular question),had issues with mounting storage devices not formatted to exclusively to linux.
that is obviously not verbatim,and i would have to to find it.
but the article is from two months ago,and the info provided referenced Linus Torvalds comment on the matter.

in trying to find a fix,after the fact,(meaning no changes have been made to the OS prior to),i found info suggesting to install (exfat-fuse,and exfat-utils),but upon attempting that,i found both are preinstalled within the OS.

i’ll do the troubleshooting portion of your reply now,and see what i get…

This what i have…
[39708.434901] Node 0 DMA free:7456kB min:388kB low:484kB high:580kB reserved_highatomic:0KB active_anon:4576kB inactive_anon:1516kB active_file:136kB inactive_file:144kB unevictable:88kB writepending:0kB present:15988kB managed:15904kB mlocked:0kB kernel_stack:0kB pagetables:36kB bounce:0kB free_pcp:0kB local_pcp:0kB free_cma:0kB
[39708.434908] lowmem_reserve[]: 0 1770 1770 1770 1770
[39708.434911] Node 0 DMA32 free:145084kB min:145152kB low:156316kB high:167480kB reserved_highatomic:2048KB active_anon:476444kB inactive_anon:493216kB active_file:70940kB inactive_file:38428kB unevictable:15468kB writepending:596kB present:1941248kB managed:1885668kB mlocked:64kB kernel_stack:9360kB pagetables:23540kB bounce:0kB free_pcp:1644kB local_pcp:1644kB free_cma:0kB
[39708.434917] lowmem_reserve[]: 0 0 0 0 0
[39708.434920] Node 0 DMA: 1004kB (UME) 838kB (UME) 3416kB (UME) 1432kB (UM) 1564kB (UME) 13128kB (UME) 3256kB (M) 2512kB (ME) 11024kB (U) 02048kB 04096kB = 7496kB
[39708.434933] Node 0 DMA32: 24007
4kB (UMEH) 49858kB (UMEH) 49316kB (UMH) 1232kB (H) 864kB (H) 2128kB (H) 1256kB (H) 0512kB 01024kB 02048kB 04096kB = 145204kB
[39708.434946] Node 0 hugepages_total=0 hugepages_free=0 hugepages_surp=0 hugepages_size=2048kB
[39708.434947] 154423 total pagecache pages
[39708.434956] 268 pages in swap cache
[39708.434958] Swap cache stats: add 2053911, delete 2053640, find 2169848/2848455
[39708.434959] Free swap = 2758932kB
[39708.434960] Total swap = 3885588kB
[39708.434961] 489309 pages RAM
[39708.434961] 0 pages HighMem/MovableOnly
[39708.434962] 13916 pages reserved
[39708.434963] 0 pages hwpoisoned
[39708.434967] SLUB: Unable to allocate memory on node -1, gfp=0xc0(__GFP_IO|__GFP_FS)
[39708.434970] cache: radix_tree_node, object size: 576, buffer size: 584, default order: 2, min order: 0
[39708.434972] node 0: slabs: 210, objs: 4641, free: 0
[66352.314623] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=10.67.0.135 DST=224.0.0.252 LEN=52 TOS=0x00 PREC=0x00 TTL=255 ID=18810 PROTO=UDP SPT=5355 DPT=5355 LEN=32
[66352.314853] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=fe80:0000:0000:0000:a9d6:4c9f:f744:27c0 DST=ff02:0000:0000:0000:0000:0000:0001:0003 LEN=72 TC=0 HOPLIMIT=255 FLOWLBL=433642 PROTO=UDP SPT=5355 DPT=5355 LEN=32
[66352.644622] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=10.67.0.135 DST=224.0.0.252 LEN=52 TOS=0x00 PREC=0x00 TTL=255 ID=18823 PROTO=UDP SPT=5355 DPT=5355 LEN=32
[66352.644843] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=fe80:0000:0000:0000:a9d6:4c9f:f744:27c0 DST=ff02:0000:0000:0000:0000:0000:0001:0003 LEN=72 TC=0 HOPLIMIT=255 FLOWLBL=433642 PROTO=UDP SPT=5355 DPT=5355 LEN=32
[66352.894445] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=10.67.0.135 DST=224.0.0.252 LEN=52 TOS=0x00 PREC=0x00 TTL=255 ID=18858 PROTO=UDP SPT=5355 DPT=5355 LEN=32
[66352.894655] [UFW BLOCK] IN=tun0 OUT= MAC= SRC=fe80:0000:0000:0000:a9d6:4c9f:f744:27c0 DST=ff02:0000:0000:0000:0000:0000:0001:0003 LEN=72 TC=0 HOPLIMIT=255 FLOWLBL=433642 PROTO=UDP SPT=5355 DPT=5355 LEN=32

When you have time,please,let me know what you think…
it’s a bit of a difficult position to be in,because i cant even reinstall the OS from the thumbdrive i originally used.

i’m generally pretty reasonable,and for all of your sake,(lets say i wear out my welcome by asking whats perceived as too many questions),i can’t even switch to a different distro to alleviate that for you…lol

So,any solution that allows me to either fix the issue,reinstall,or install something different are things i’m open to.

This post was flagged by the community and is temporarily hidden.

Hi guys !

@nova, i have the same issue with the exfat type file system (your first screenshot). For the
sudo dmesg | tail -25 , i have a different result:

I have try to find a reponse on the internet,without finding anything.

This is the most command used fort the problem: sudo apt install exfat-fuse exfat-utils

And after that, make sure you have restart your computer but for me, that doesn’t work.

See you soon !

@nova first try

mount.exfat-fuse /dev/sdX /mnt/exfat
where /dev/sdX is the device file, /mnt/exfat is a mountpoint.

if this works then
run ln -s /usr/sbin/mount.exfat-fuse /sbin/mount.exfat

Update information
Screenshot at 2020-07-17 11-39-35

4 Likes

Thank you !
I had the same problem with exfat USB key and this worked for me.

that makes sense,and looks like it should work,in theory…
though,when i try it,exactly as you have it listed,i get nothing.

i feel it’s likely user error on my behalf,as if i’m leaving something out…?
i just started working with symlinks not long ago,so my question is likely to be off…
are you saying i should add whatever device is to be mounted here,or is the way you have it listed the way it should be entered verbatim?

i feel as if somehow enabling exfat is what the goal is,not necessarily creating a symlink for every device which is formatted that way…
please,correct where i am wrong here…

so,for example.
where you have "/dev/sdX " am i to replace that “x” with what ever is listed as the desired device to be mounted?
which for me would be /dev/sdb,in the case of my micro SDcard…

because when i try it either way,i still get these errors…

sudo mount.exfat-fuse /dev/sdX /mnt/exfat
[sudo] password for nova:
FUSE exfat 1.3.0
ERROR: failed to open ‘/dev/sdX’: No such file or directory.
┌─[✗]─[nova@parrot]─[~]
└──╼ $sudo mount.exfat-fuse /dev/sdb /mnt/exfat
FUSE exfat 1.3.0
ERROR: exFAT file system is not found.

Good news!
i skipped step 1,and went directly to step two,which allowed me to mount the device…
i can’t tell you how thankful that i am…
it’s greatly appreciated!

Yeah it work but manually not automatically…

So my question is: how make the mounting system automatic same before the last update?

I’ve asked that before,but,for me,automount was never enabled by default.
reading through the (what parrot supports thread),you’ll find this listed.
Functions enabled by default.

  • Firejail
  • AppArmor
  • uBlock Origin
  • Noscript
  • Privacy Badger

Functions disabled by default.

  • automount

but i’m not sure how often that list is updated…?

Yeah, parrot don’t automount the disk but before the last update, we can have the possibility to mount the disc manually via the icon ^^

if you mean the applet,or the option available in the system manager,@I_Have_Treasure reply is what resolved that for me.

Yeah, it work finally

Can you help me please for my last post ?

You’ll have to clarify a bit more,i don’t see what you are talking about…?
if you talking about the position of the red,green,and yellow tabs,those change with applying different themes.

Yes,

I talk about the postion of the red, green and yellow tabs. They have change suddenly and if i try to change the theme, i’m staying at the “bug” position.

Its looks like this, before and after(now “bug”):

(i have take the first pictures on the web for the example)

okay,i see it now.
unfortunately,i’m not aware of a fix for that,but,you could probably create a new post regarding that particular issue.
it’s not likely to be answered in this post,because it’s regarding a different issue…
good luck!