Unable to start TOR Browser - Parrot 4.0

Can Anybody help … ??

Error : Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start.


Have the same problem, and I can’t copy the tor log. It is empty.

Same probleme here. Reinstall over the Tor Launcher Settings doesn’t fix it.

Yeah . I was having problem with tor but I think … latest Parrot updates fixed the issue …

debian fixed the bug, just keep your system up to date

I think I got everything up to date, but still the same problem.
Is there another way to update the system?
I use: apt-get update and apt-get dist-upgrade

@Necrosamson - apt-get update; apt-get upgrade; apt-get dist-upgrade

Thx, but everything seems up to date and Tor is still bugged :sob:.

1 Like

@Necrosamson - Yes , you are right … TOR is still bugged … Actually it was working after the updates, but now it is not …

I just install 4.0 today, this is still current. Not a big deal to me. But just so everyone is aware. I got same error and everything.

Have the identical issue here. By updater and by terminal the system shows up to date. My anonsurf works fine

cp /etc/anonsurf/torrc /etc/tor/torrc
service tor restart

This solution doesn’t work

copy your torrc file here
And anonsurf work?

no problem with me i just install torbrowser-launcher, i have a problem with the tor signature verfification but i install the pip service-identity which was not the good one on my pc, and after that no problem to launch tor browser.
but for me i remove firejail of my distro for multiple reason and one is tor app were fucked…

Just to say Palinuro but onioncircuits is launch by default with python2 or this is a python3 script so for launching i make an 1000e alias onioncircuits=“sudo python3 /usr/bin/onioncircuits” :wink:

It’s not working …

Before all when you start your torbrowser make a ps -A | grep tor just to see if tor launch correctly the process…

Remove privoxy and do a sudo apt install --reinstall tor torbrowser and if still unable to work…

Remove and purge all your tor package
and privoxy and polipo if installed. uninstall anonsurf too

and after that just install this package:

sudo apt install anonsurf torbrowser-launcher tor
yeah i know there is no need tor because thats a dependency blablabla but do it

and come back if there is some problem but i repeat it for all and palinuro the firejail is a cool idea, safe etc etc but thats a fucking headache to configure new app or unblacklisted them. I remove firejail and a lot of bugs/tor app work fine now

I repeat for me all work and i have just install it.

1 Like

Yes annon surf is working perfectly, here is my torrc from tor :

##define virtual network mask
AutomapHostsOnResolve 1
AutomapHostsSuffixes .exit,.onion

#define tor ports and explicitly declare some security flags
TransPort IsolateClientAddr IsolateSOCKSAuth IsolateClientProtocol IsolateDestPort IsolateDestAddr
SocksPort IsolateClientAddr IsolateSOCKSAuth IsolateClientProtocol IsolateDestPort IsolateDestAddr
ControlPort 9051
HashedControlPassword 16:FDE8ED505C45C8BA602385E2CA5B3250ED00AC0920FEC1230813A1F86F

#use tor to resolve domain names

RunAsDaemon 1

#use hardware accaleration when possible for crypto
HardwareAccel 1

#socket safety hacks
TestSocks 1
AllowNonRFC953Hostnames 0
WarnPlaintextPorts 23,109,110,143,80

#dns safety hacks
ClientRejectInternalAddresses 1

#circuit hacks
NewCircuitPeriod 40
MaxCircuitDirtiness 600
MaxClientCircuitsPending 48
UseEntryGuards 1
EnforceDistinctSubnets 1

try what i say before :wink: maybe a conf problembecause i have just intsall when i saw this post and all work properly for me and if dont work try to rmeove firejail (you can reinstall it after this test :wink: )

You can also add Tor Browser to your desktop’s application menu.
Copy and paste