1. OS version:
DISTRIB_ID=Parrot DISTRIB_RELEASE=4.10 DISTRIB_CODENAME=rolling DISTRIB_DESCRIPTION="Parrot 4.10" PRETTY_NAME="Parrot GNU/Linux 4.10" NAME="Parrot GNU/Linux" ID=parrot ID_LIKE=debian VERSION="4.10" VERSION_ID="4.10" HOME_URL="https://www.parrotsec.org/" SUPPORT_URL="https://community.parrotsec.org/" BUG_REPORT_URL="https://community.parrotsec.org/"
2. Kernel version:
Linux parrot 5.10.0-3parrot1-amd64 #1 SMP Debian 5.10.13-3parrot1 (2021-02-25) x86_64 GNU/Linux
- Did you try searching info about this issue on search engine?
Yes, but my problem is specific
3. How did you get this error? Are there any steps to procedure it?
I was trying to upgrade my system normally, but I noticed that there is one package which always not being upgraded, which is “regripper”. Anyway, when I try to upgrade it, the terminal show “packages have unmet dependencie” error.
4. Error log or screenshot
This is my command:
sudo apt install regripper
This is the output:
Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: regripper : Depends: kali-defaults (>= 2019.3.6) but it is not installable E: Unable to correct problems, you have held broken packages
5. If you have any idea or suggestion about this issue please tell us
I was thinking to manually download and install “kali-defaults”, but I’m afraid to broke something within the system
Any suggestions please, to upgrade this package, and solve the unmet dependencies problem