Unable to update a package because of unmet dependencie

1. OS version:

PRETTY_NAME="Parrot GNU/Linux 4.10"
NAME="Parrot GNU/Linux"

2. Kernel version:

Linux parrot 5.10.0-3parrot1-amd64 #1 SMP Debian 5.10.13-3parrot1 (2021-02-25) x86_64 GNU/Linux

- Did you try searching info about this issue on search engine?
Yes, but my problem is specific

3. How did you get this error? Are there any steps to procedure it?
I was trying to upgrade my system normally, but I noticed that there is one package which always not being upgraded, which is “regripper”. Anyway, when I try to upgrade it, the terminal show “packages have unmet dependencie” error.

4. Error log or screenshot
This is my command:

sudo apt install regripper

This is the output:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 regripper : Depends: kali-defaults (>= 2019.3.6) but it is not installable
E: Unable to correct problems, you have held broken packages

5. If you have any idea or suggestion about this issue please tell us
I was thinking to manually download and install “kali-defaults”, but I’m afraid to broke something within the system

Any suggestions please, to upgrade this package, and solve the unmet dependencies problem

Thank you for reporting. We know that problem and it will be fixed after we create whole pentest tool list for Parrot OS and maintain all packages by ourselves.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.