Update hangs at 75%

Hi Parrot users,

Newbie user of parrot os, and i don’t if this topic has been answered already.
I keep on updating my os and it keeps hanging on 75%, its my 5th time to restart the whole process but unfortunately same result. Hope someone would answer my concern. Thank you in advance

What version of Parrot are you running? (include version, edition, and architecture)
Parrot Sec 4.5

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard

Configured to multiboot with other systems? (yes / no)
Yes i have Windows 10 pro

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

If you are actually using 4.5.0, there is an update to 4.5.1 on the website. If you just downloaded it its probably 4.5.1. Normally, we are told to only use sudo parrot-upgrade. But in this instance, what has worked best for me has been:

As soon as you boot up from install.

Thank you for your reply. What is the differene between parrot-upgrade and dist-upgrade?
actually i used the dist-upgrade but sadly it hangs again on 75%

So you are updating not installing right?

The difference is absolutely nothing except the wording used. Its intended to not only “match” a lot better but also cut down on people having to
A) run apt update and dist upgrade because parrot upgrade is all in one.
B) reduce confusion and the usage apt upgrade fatal command which breaks parrot systems because its a rolling distro and thats not supposed to be used and can cause all kinds of weird things and bad birds.

1 Like

Yes sir im updating, actually im in progress again hope it works
Current commands that i use:
Apt update

How did this turn out? Fix your error?

Not yet sir. Im trying it again as of the moment but when i tried to install it thru virtual box everything is smooth? Is there something to do with my hardware?

Well Yes , but no :joy:

Exactly not able to tell that its hardware error || possible packages which going to download at 75% have misconfiguration with your system || possible broken dependencies

Thank you for your reply. At last my update push thru and finished wothout error but i have a new problem…
I rebooted my machine and the grub suddenly disappear so it went directly to windows. Searching for solutions right now …

Already topic created on that

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.