Update/Install 4.6 failing on MacOS vmware 11.1!

I updated a working vmware 4.3 install to 4.6 and everything fails.
Mostly the old working grub boot loader updated to 4.6, fails!

Also creating a new virtual machine with 4.6 security iso amd64 fails when installing the grub boot loader.

  • updating the working 4.6 security virtual .ova results in a not booting system.

iMac 2017, vmware 11.1, parrot security amd64 iso/ova

Don’t get me wrong, but I was able to install 4.3 several times on my iMAC with dualboot and on several vmware and virtual boxes.
But this update crashed all my installs. Lucky me having a backup.

Grub boot loader error all the time. That was an issue with 4.3 too, but managable …

Is there a step by step video available for imac macOS and vmware 11.1 to install parrot 4.6?
I understand that making videos for all machines is to much, but for MAC it isn’t!

Thanks in advance


Hello. Can you please be more specific in “everything fails”? Does the system boot? Or does it stop at initramfs?

with everything fails I meant everything with the Grub boot loader.
On already installed installations after the update (if the update worked until the end).
With 4.3 + update or 4.6 .ova + update, Grub got killed/not working anymore.
At the end of a new install when installing Grub, it can’t work/write Grub on an virtual machine path.

For a new install or an update, when started up, you only get a black screen.

But you can boot the vm from iso and chroot into your installation … :wink:


no idea how to do that?
I can boot as live mode parrot from the iso or use the .ova file to create a virtual machine, but no idea how chroot into a non bootable installation of vmware machines.

first of all we should clear something:

  • can you boot the 4.6.iso in live mode or deploy a new vm with the 4.6 ova with your vmware workstation version?
  • how did you upgrade the old vm? … apt upgrade?
  • are important data in the vm?
  • can you send us some pictures when the vm is booting?

for chrooting into a non running system pls have a look at THIS or any other posts here in the forum.


  • yes i can boot the 4.6.iso in live mode or deploy a new vm with the 4.6 ova with your vmware workstation version 11.1.

  • I updated/upgraded using the automatic checkup popup for updates and tried also via ‘sudo parrot-upgrade’

  • I didn’t kill my important install, because I had backups of the virtual machines. I didn’t update my imac install yet, because I try updates first on a virtual machine most of times.

  • after the update, it boots as black screen with all the text lines containing the green and red alerts, then starts flickering on/off showing this process of booting text lines. After a minute it stops and shows the lines on random positions on the screen and stops doing a thing.

Also some times booting is not coming that far.

Fresh installing in GUI mode makes an installation hang several times, so you have to suspend it for a minute and then resume it and it continues. Grub also fails in GUI mode.

imac macOS 10.14.6 + vmware 11.1

mate, we need some error messages to help you! pls make some screenshots or a video. Should be simple cause it´s a vm.


here you go.
I made screenshots for 3 different scenarios as pdf files archived as .tar.gz,
because it was to big to upload. (10.6MB)

You’ll find :
– Parrot-security-4.6_virtual.ova-UPDATE.pdf
this failed

– old parrot 4.3 installed VM - UPDATE try.pdf
this failed

– parrot 4.6 iso install and update -worked this time.pdf
worked this time by following the same instructions like last time it failed… ???

Thanks in advance

Looks like it is Debian specific VM problem on OSX platforms, because many people with OSX had this problem.

The bad thing is that we are not able to reproduce it as none of developers don’t use MacBook, but you can help us if you follow this guide: https://unix.stackexchange.com/a/531984/338435

If it works we can figure out what’s wrong, make a post script or something, but I feel that it is not parrot related, but Debian related, and I would like you to open a bug on https://bugs.debian.org/.

That can take a while and not guarantied that I can make it work.
I have no idea what it is. Also it’s about virtual box, and not vmware.

But pretty sad, that no one has access to a mac/imac.
Makes support for me useless. :frowning:

And macOS is heaps closer to Linux than Windows virtual machines.
Virtualbox isn’t by far that good as vmware is…!

Anyways, thanks for your try.
I gonna wait until Parrot Version 5.
Pretty sad too, because if Parrot runs on my mac (not virtual) it’s a beast and flies like a hawk.

it is also posible to do this with vmware.

  • edit config from your vm
  • add a cdrom drive if not there
  • select the parrot.iso
  • boot from the iso

chroot and fix your system like descripte in the link.

Here are the wired ending screenshots after the update and restart…

25%20pm 40%20pm