Update Problem Dependencies

When i try to upgrade system
sudo apt-get update this shows up
he following packages have unmet dependencies:
libc6-dev : Breaks: libgcc-9-dev (< 9.3.0-5~) but 9.2.1-4 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. Any solution ? Ps: Even when i try sudo apt-get upgrade --force it wont work.
Thanks.

first thing to remember is
never use apt-get to update the system
you can use it elsewhere
always use
sudo parrot-upgrade to fully upgrade the system
and about the dependency, you can try this

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.