Update/Upgrade Issues

Briefly describe your issue below:
Repositories no longer signed. Ran sudo apt update in root terminal. Have updated the /etc/apt/sources.list.d/parrot.list to that found in https://docs.parrotlinux.org/mirror-list/ with the following:

deb https://deb.parrotlinux.org/parrot/ rolling main contrib non-free
#deb-src https://deb.parrotlinux.org/parrot/ rolling main contrib non-free
deb https://deb.parrotlinux.org/parrot/ rolling-security main contrib non-free
#deb-src https://deb.parrotlinux.org/parrot/ rolling-security main contrib non-free

someone mentioned to configure the resolv.conf file in this link , https://community.parrotlinux.org/t/my-upgrade-issues/11709 , but did not say what they did/added to that file. Also i have tried restarting anonsurf, but still no luck. Please help, thank you. I am a new member here :smile:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Distributor ID: Parrot
Description: Parrot GNU/Linux 4.8
Release: 4.8

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

└──╼ $sudo apt update
[sudo] password for anonymous: 
Err:1 https://deb.parrotlinux.org/parrot rolling InRelease
  403  Forbidden [IP: 443]
Err:2 https://deb.parrotlinux.org/parrot rolling-security InRelease
  403  Forbidden [IP: 443]
Reading package lists... Done
E: Failed to fetch https://deb.parrotlinux.org/parrot/dists/rolling/InRelease  403  Forbidden [IP: 443]
E: The repository 'https://deb.parrotlinux.org/parrot rolling InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://deb.parrotlinux.org/parrot/dists/rolling-security/InRelease  403  Forbidden [IP: 443]
E: The repository 'https://deb.parrotlinux.org/parrot rolling-security InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Check the contents of /etc/apt/sources.list. Make sure that either everything is commented out or deleted. Then check that /etc/apt/sources.list.d/parrot.list contains:

 1 # parrot repository
 2 # this file was automatically generated by parrot-mirror-selector
 3 deb https://deb.parrot.sh/parrot/ rolling main contrib non-free
 4 #deb-src https://deb.parrot.sh/parrot/ rolling main contrib non-free
 5 deb https://deb.parrot.sh/parrot/ rolling-security main contrib non-free
 6 #deb-src https://deb.parrot.sh/parrot/ rolling-security main contrib non-free

Once those are good to go just:
sudo parrot-upgrade

1 Like

Hi mokeefe thank you for helping, but still not working, i did exactly as you said. the output errors are same as before
the file in /etc/apt/sources.list.d , parrot.list contains exactly what you said

Hope you can help, or someone can help who faced the same issue.


Still not able to resolve this issue, but have made an interesting find. when i start anonsurf, and while anonsurf begin setting up and making connection, during this time, in a separate terminal, i keep using and trying the sudo apt update command, after a while, it successfully updates, then i quickly use sudo apt upgrade, which works. it is a bit of hit and miss. it seems the issue is with anonsurf. has anyone come across this same issue, and how they resolved it?
thank you

I have actually come across this before. Could be a couple things.

Is your computer’s clock set to the right time/date?

Hi mokeefe, thank you for getting back and helping me with this issue. The time and date is set correctly. the sudo apt update and sudo apt upgrade only works during the start up phase of anonsurf - so while anonsurf is starting and only during that time when i use the sudo apt update and upgrade that the update and upgrade works - bit of a hit and miss - its really a strange issue, can seems to work it out othrt than its to do with anonsurf.


Don’t try to use update while using anonsurf, and you should have no need to modify the sources list unless you have a problem updating.

Hi muroga
thank you for helping.
I can only get online when i use anonsurf, and it worked fine before. When anonsurf is not in use, i am unable to get online. Have you had this issue before?

are you forgetting to issue sudo anonsurf stop before shutting down or rebooting your computer?

If you are forgetting to issue anonsurf stop before shutdown/reboot (during an anonsurf session) you will reboot into a system where some of the network settings from previous anonsurf run prevent your network connections from working properly.

If this is the case try issuing sudo anonsurf stop during one of these problem moments.

It is both not safe to upgrade over tor and heavily slows down your connection/results in 403 errors.

Hi RightToPrivacy
Thank you for helping. i always stop anonsurf before shutting down or rebooting. Used to be able to access the internet without anonsurf, but one day after an upgrade,( this was some time ago) it just stopped, so used anonsurf to access the internet. This this be an issue with the resolv.conf file, what should be in this file, what should i see here? because if this could be the cause of the issue im having, this also could be the solution to the update issue?


Hi all.
I am still unable to resolve this issue. Please can someone help? Hope you all are well.


please do issue:

sudo anonsurf stop

Just in case there was an instance you forgot to stop it. Anonsurf makes many changes to your internet and if you forgot even once, it can give you this problem continually until you reverse the settings/routing.

So please, issue:

sudo anonsurf stop

it will not harm your system even if issue is unrelated. It just ensures you undo anything anonsurf may have carried over when one forgets to stop it. Issue that command and then open a new browser (Open new browser ONLY after issuing it)

We will go from there.

I am unsure if this problem is particular to few people. I have been dealing with this since the recent iso i downloaded from the Parrot OS. till date, i am still unable to update nor upgrade my repositories. i have searched different forum and nothing is coming up yet.

Does anyone has a non try and error method to overcome this apt update and upgrade issue (resolving error and forbidden shit)??

it sounds like you may be using tor during your upgrade attempt. Forbidden (403 error) most of the time is because of an attempt to upgrade while under anonsurf/tor routing.

Did you forget to stop Anonsurf?

Hi RightToPrivacy
Sorry for the late reply, but thank you for getting back and helping.

Anonsurf have been stopped completely, but still the same issues for the update and upgrade. Seems to when i do not use anonsurf, i unable to get online . A question, what should i expect to see on the file called resolv.conf, as i feel this is what is stopping me from getting online, unless i use anonsurf.


Hi bingoxn

thank you for getting involved to solve this issue. I agree with you, think this is something that effects a large number of Parrot OS users. For me to get the update and upgrade to work, i start anonsurf, and while it is starting, i keep trying update command till it works - yep, not a good idea , but thats what works for me, and i do the same for the upgrade - again, not a good method, but at this moment, its the only thing i can do to get it to work.


Hi James. I was able to resolve my issue by editing /etc/resolve.conf. In the file (if you look) is “nameserver”. If you want a direct connection to internet you can edit the file and add another nameserver. The choice of nameservers is yours. You can use cloudflares or googles as an example. So when you edit the file (as superuser) it should look similar to this:
nameserver (or or whatever)
Then open up a terminal and type “sudo /usr/bin/parrot-upgrade”
That should do it. It worked for me.

Hola, quiero ayuda con un problema que tengo.
cuando ejecuto el comando apt-get update tengo esta respuesta, no se como solucionarlo…
Hit:3 https://deb.parrot.sh/parrot rolling InRelease
Hit:4 https://deb.parrot.sh/parrot rolling-security InRelease

Ademas de tener otros errores con el repositorio de spotify porque intentè instalarlo pero no logrè tener exito.

Hi cm0ss

Thank you so much for your help, i have tried your method , and it works perfectly, thank you so much, fantastic! so over the moon.

But i noticed that when i restart the laptop, it goes back to the original file, just the "nameserver, is this normal?