Updates Break Gnome-Evolution - Kmail has no Dark Mode

Updates Break Gnome-Evolution

Let me preface that I am not a computer programmer or expert, I just have some basic familiarity with using a Linux desktop.

I’m running ParrotOS Home in VirtualBox, and for the most part, everything is working fine.

However, when I run sudo apt upgrade or sudo parrot-upgrade it causes gnome evolution mail client to stop launching a graphical window after a reboot. The processes still show in system monitor.

System Specs, below.

I tried this on a fresh install without changing any settings, and the issue is reproducible.

I’ve tried sudo apt remove apparmor, and I’ve verified that sudo apt update and sudo apt autoremove do not cause any problems.

I’m also able to run Kmail and Thunderbird fine, but I cannot figure out how to enable dark mode in Kmail, and I don’t like Thunderbird’s telemetry settings.

Can anyone recommend how to fix this, or a working dark mode no-telemetry alternative?

Manjaro (arch) Plasma - Current
AMD Radeon graphics card
20x intel core
60 gb ram

VirtualBox Guest:
ParrotOS Home - Current
Encrypted install
10GB Ram
2 cores
128 video ram
Virtualbox tools extension pack
Vnc extensions pack
VERSION=“5.0 (Electric Ara)”

Kmail, afaik, is using QT framework, so it’s acts different from GTK apps.
Evolution is using fine on my pc, latest update

Thanks for the fast reply on this.

Did you do an update or and upGRADE?

Update works fine for me, but upgrade is what breaks it.

Are you using virtualbox?

Can I install QT fraework to get kmail to run in dark mode?

appreciate the help! :robot:

Open the bottom menu and type “check for update” and use it
I don’t apps using qt framework. IDK about this

It’s not an update issue; it’s an upgrade issue.

UPDATE: not sure how to update this thread but basically I got it to work by searching for and deleting all evolution files, then reinstalling as a flatpak.

I experienced missing columns in trying to use claws-mails but it looked like it might be a good alternative.

Never got kmail dark mode to work.