Upgrad Error for IPTables

Briefly describe your issue below:

Error upgrading from new installation of Parrot 4.3. Maybe I just need to get some new dvds and download the new ISO?

Setting up libvlc-bin:amd64 (3.0.4-3+b3) …
Setting up iptables (1.8.2-2) …
update-alternatives: warning: forcing reinstallation of alternative /usr/sbin/iptables-nft because link group iptables is broken
update-alternatives: warning: forcing reinstallation of alternative /usr/sbin/ip6tables-nft because link group ip6tables is broken
update-alternatives: warning: forcing reinstallation of alternative /usr/sbin/arptables-nft because link group arptables is broken
update-alternatives: warning: forcing reinstallation of alternative /usr/sbin/ebtables-nft because link group ebtables is broken
Setting up libhtml-parser-perl (3.72-3+b3) …


What version of Parrot are you running? (version 4.4, Home edition, AMDx84 architecture)

What method did you use to install Parrot? (Debian GTK )

Configured to multiboot with other systems? (no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

They are only warnings, so i wouldn’t worry.

But i would recommend using the newest ISO when you install the system.

Yes this is old, use 4.4

Installed and running newly downloaded 4.4. Same issues. Still updated 90 packages, still have the gtk3 error, but only 4 of them this time. Been looking at a couple of packages. There is no GTK3.pm that I can find. But the(appmenu-gtk3-module—GtkMenuShell D-Bus exporter (GTK+3.0)) and the (libatk-adaptor—AT-SPI 2 toolkit bridge) descriptions sound like they might also address my anonsurf problem. But I have no science on that assumption.

Give them a go, the only way to learn your system is by breaking it a few handfuls of times and learning how you did it and how not to avoid it in the future. Definitely need some perl modules though