Upgrade- Lost Packages and KDE

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
  3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    PRETTY_NAME=“Parrot GNU/Linux 4.10”
    NAME=“Parrot GNU/Linux”

  • Kernel version: run uname -a
    System: Kernel: 5.9.0-2parrot1-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.19.5
    Distro: Parrot GNU/Linux 4.10 base: Debian parrot
    Machine: Type: Desktop System: LENOVO product: 90JF005MUS v: Legion T730-28ICO serial:
    Mobo: LENOVO model: 36E9 v: SDK0R32862 WIN 3258146600023 serial: UEFI [Legacy]: LENOVO v: O3NKT24A
    date: 08/01/2019
    CPU: Info: 8-Core model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Kaby Lake rev: D L2 cache: 16.0 MiB
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115200
    Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
    9: 800 10: 800 11: 801 12: 800 13: 800 14: 800 15: 800 16: 800
    Graphics: Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: Micro-Star MSI driver: nvidia v: 450.80.02 bus ID: 01:00.0
    Display: x11 server: X.Org 1.20.8 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa resolution:
    1: 3840x2160~60Hz 2: 3840x2160~60Hz
    OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 direct render: Yes


** ISO information **

Parrot-KDE- Home
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

4. How did you get this error? Are there any steps to procedure it?

  1. Today saw there was an update and ran Parrot-Upgrade, which removed some packages, including KDE desktop. Re-installed KDE desktop, but having some issues getting back icons.
  2. I think theres also an issue with package, qt5-default, broken package dependencies with libqt5gui5-gles and qtbase5-gles-dev.
  3. GTK theme settings gone in the application style menu
  4. why did these packages get removed?

I tried using different themes, icon set, deleted icon cache, still doesn’t come up.

5. Error log or screenshot

Here’s the upgrade:


6. If you have any idea or suggestion about this issue please tell us

** Your information **

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

Thank you for the report! Likely the problem is from Debian side and well we are trying to understand this problem then tell Debian KDE team about this.

Bug spotted. libqt5gui5 and libqt5gui5-gles is the problem.

Yes, I mentioned the fix in Telegram

From what I can tell the gles package is nowhere to be found in my fs and it still wants to remove kde. So I’m still unable to upgrade and have no libqt5gui-gles to purge neither before the update nor after.

p/s: from screenshot, bug is confirmed on Ubuntu KDE as well.

1 Like

That’s rare, I didn’t experience those issues and recently upgrade my system automatically, I just installed KDE Security ISO and it is working fine. Also I couldn’t find libqt5gui5-gles but libqt5gui5.

if you try sudo apt insatll qt5-defaults or something like that i’m sure you’ll see the error. The problem could be fixed from Debian side.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.