USB 2.0 not working after OS loads

– Please Write here your help request –
After booting into the live install anything attached to my USB 2.0 does not work. I have swapped out hardware between 2.0 and 3.0 and confirmed the issue is with the 2.0 connections only.
All connections work in BIOS. If I have mouse on 2.0 and keyboard on 3.0 it will recognize both, same if I swap them. The grub screen also recognizes the keyboard regardless of whether or not it’s plugged into the 2.0 or 3.0 connector, so this is something weird going on with the OS itself. At every point prior to booting into the OS from USB, both the 2.0 and 3.0 connections work. Parrot starts… USB 2.0 dies. I tried disabling Legacy USB support and this did nothing.
The USB stick is on a USB 3.0 connector.

EDIT to add that if I plug the USB stick into one of the USB 2.0 connectors it will boot into the grub installer, but if I try to proceed it hangs. It then gives me a never-ending string of “UNABLE TO ENUMERATE USB DEVICE” errors.
This, again, despite all USB connections working in BIOS.

EDIT again to add that I’ve now tried three separate varieties of Linux ISO and none of them are recognizing USB 2.0 when booting into the various live distros.

In the immortal words of Socrates: “WAT”

EDIT THE FINAL
Enable IOMMU in BIOS. It didn’t fix things EXACTLY. USB 3.0 is now disabled but USB 2.0 works. Just for the record, this motherboard has been in use for about ten years, running Windows, with no USB issues whatsoever. I’ve also had various Linux distros installed at various times without issue, but now it decides to do this. I’m wondering if there’s been a recent kernel update that fragged compatibility with this motherboard or something else equally weird. Whatever the case, we’re installing so let’s call this one solved for the moment.

  • ParrotOS iso in use:
    Parrot-security-5.0.1_amd64

  • Application used for flashing the iso:
    balenaEtcher 1.7.9

  • Logs/Terminal output (use pastebin or similar services):
    N/A

  • Screenshots:
    N/A