Usb device not mountable

Briefly describe your issue below:
When I connect my SanDisk USB 3.1 16GB drive the system does not recognize it. I tried formatting it differently and there was no change. I use a USB 2.0 SanDisk 16 GB drive and it is recognized immediatly.


What version of Parrot are you running? (include version, edition, and architecture)
Parrot Security 1.18.0 64-bit
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
standard debian
Configured to multiboot with other systems? (yes / no)
yes, Windows 10
If there are any similar issues or solutions, link to them below:


If there are any error messages or relevant logs, post them below:
no errors or logs

Maybe it is because your computer does not support USB 3.x, meaning that it cannot give enough power to your usb drive and cannot read any of the files inside there (because of the protocol. No formatting in your other drive would make it mountable).

I have a 2018 HP omen. All the USB ports are usb 3.1

Do you have privileges to admin usb input devices?

Yes, what I don’t get is that it is fine with another drive. The USB drive works in mint, mac, and windows. Should I try signing in as root to see if the issue is in the account itself?

@Maxxxxxx2.0 Maybe you should check if there is any problem with the usb and maybe loging in as an admin could help.
Or maybe you are using a format that is not readable from the linux machine. It has happened to me with ExFAT formating but any other formating is readable by parrot linux.

Maybe try formating it as FAT(-32) and see if that fixes the issue.

Can you just not see it in file explorer?
Or can you not even see it when you run sudo fdisk -l
I have had SD cards that dont show up in the file explorer but are still mountable from the command line.

I type lsblk, which shows me all mounted or mountable drives. I get the SDA which has windows and the NVME0 which is where parrot is installed. There is nothing for sdb, which should be the USB, showing up.
I did try formatting it differently again.

Can you see it in gparted? Are all of your user advanced allowances boxes checked and have you configured your root passwords etc just to cover your bases? What is on the drive? What is the output of Lsusb?

The output of lsub is:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0bda:58eb Realtek Semiconductor Corp.
Bus 001 Device 003: ID 8087:0aaa Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
When using Gparted there is only the two OS drives.
All boxes are checked in the advanced user settings, allowing me to do anything on the system.
On the drive is an encrpted file, .txt files, .mp3, .pdf, .jpg, .key, and .exe files. All of the files show up in linux mint on another machine.

Have you installed udev and added yourself to the allowed group? Is your system also encrypted? (Let’s rule out the crypt as a possibility cause that’s a possibility)maybe also check to make sure your caja-dev and admin packages were also added cause they just make life easier in general. I will be checking this periodically tonight if you want to work on it with someone so you can get your files back but you may have to access them in another os and reformat the drive if we still haven’t made progress.

I am installing udev and no the rest of the system is not encrypted. I am transferring files to reformat the drive. I try to install udev or bumblebee-nvidia and the terminal hangs on the following:
Preparing to unpack …/nvidia-legacy-check_390.87-2_amd64.deb …
Checking for legacy NVIDIA GPUs appears to hang, try rebooting with ‘acpi=off’
added to the kernel boot options in the GRUB configuration
what is acpi=off? I can’t find it in bios.

I got the acpi=off that sort of helped improve the shutdown issue I have in another post

I’m glad you at least got one major issue solved! That’s an annoying one too (at least with my build it was). Check your safe boot Params in bios that may be why it’s not allowing you to load the encrypted usb. What bios are you running? I can absolutely help you if it’s gigabyte but unfortunately I’ve been rather brand loyal the past few years and really haven’t seen another brand of bios in too long (Lenovo doesn’t count for me haha) also I apologize I got distracted big time soldering some headers but hey I got a lot done at least! :blush:

Cool! The brand of bios is hp, safe boot or secure boot is disabled. The entire USB drive is not encrypted though. With the shutdown issue, only the background is showing now only the background. I need to see if reinstalling bumblebee-nvidia and udev again. I reinstalled the OS twice because after trying to install with apt-get it would hang, then I close it and reboot and the OS doesn’t load. I know why that happens though. I will do more with the USB tomorrow. Thanks for the help!

You’re very welcome! I’m glad I was able to help you learn! Anytime I’m available I’ll always be more than happy to help!
Sometimes the arrow keys can trigger it to stop hanging, as for the usb I would try reformatting it after you save your files and see if it just didn’t play nicely with something.