USB Guard protection

I’ve seen this software and it is interesting
It is on the repository and maintained by Debian side. So if we can use and control it, it can be a default tool on Parrot Home

I checked it, and I see many issues with that. Haha

Wow what was the problem?

Well here it was
at first when it is installed, immediately its related daemon automatically starts and all the usbs are locked
had to go to recovery and remove that package

another is that, i started with a lower version and then later upgrades to latest one. Doing that, a new config/rule is created and old config/rule is not active (overwritten), and in new config again all the usbs are locked again

similar issues reported

I can understand the problem of overwritten rules. But locked USB can be a “feature”. Ofc it is anonying

yeah not annoying for laptops cause that can be managed but for desktop users hard to do

because not everybody wants to go in recovery mode and make rules

wait on PC, it blocks EVERYTHING from USB port includes keyboard and mouse? RIP LoL

So i guess you used it before and know how to use it. So could you create a tutorial please? ofc with strongly recommended that use it on Laptop only. I’ll tell doc team to add it in our doc.

well I couldn’t tried on desktop cuz mine one is destroyed currently. Tried on laptop, surely will make a tutorial no problem on that.

I like the idea. But it’s too soon to discuss about this. It’s still in development and it might break. USBguard does not offer isolation so you are still vulnerable to lots of attacks. Their About page on GitHub has this ‘Warning
The 0.x releases are not production ready packages. They serve for tech-preview and user feedback purposes only. Please share your feedback or request a feature in the Github issue trackers for each project:’. I would say let’s wait till it’s officially released. It also may add some attack surface as well

i just ran into some issues just now
it is on debian repo
so i used apt install
but getting forbidden ip and redirecting mirror error
tried using mirror of MIT but says no installation candidate found
tried explicit mirror directionby putting the mirror at parrot.list but still doesn’t work

tried compiling the program from scratch but is not working

configure: error: libqb development files not found!
See `config.log' for more details

i installed libqb from scratch, cloned repo

maybe there is problem in linking those?

It should need libqb-dev

yeah installed that
after that there is error

it works like charm in Kali Linux

That is weird because install on my side is tottally find. Just sudo apt install usbguard

i am getting error on the install from repo
getting mirror redirection, forbidden ip and failed to fetch errors
tried changing mirrors still not fixed
but i tried it on kali it works well

try apt download usbguard and see if it is blocked. If not, you can still use dpkg to install downloaded files. It is a little strange. Our firewall is being stupid again.

thanks for this
I not got usbguard working
should i make a tutorial or?

It’s up to you. If you think it is useful and Parrot needs it so please do it and we can learn from your configurations