USB Realtek Wi-Fi just installed parrot. Tried everything

–I need help I have a Wi-Fi adapter and just installed parrot os on a Lenovo intel core it was running windows 10 but I completely wiped everything I have the cd that installs the drivers for the Wi-Fi adapter…I tryed many options I can find online and still no Wi-Fi works or shows any networks just my wired connection works and I’m very frustrated it doesn’t even show a wlan0 someone please help me , –


  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):

  • Kernel version (if you are not aware of it, open terminal and type uname -r):

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

There are many different Realtek chipsets, we need to know which you have,
inset it in a USB port and run from the terminal inxi -N and post back the report [the CD that came with it usually only have win and mac drivers]

It says device-1: intel 82567LM-3 gigabit network driver e1000e if: enp0s25 state:up speed: 1000 mbps duplex:full and has a MAC address aswell. I do have it connected to a wired connection right now is that what that is? I’ve tried different drivers I have even searched my actual Realtek device online maybe I’m not setting it up correctly idk but it’s frustrating whenever I look it says no wlan0. I greatly appreciate the help.

If you had the wi-fi in the USB it should have been recognised, without knowing which chip set I cannot give further advice, apart from try using a different USB socket

Okay so you’re saying it’s not being read. I’ll figure that out and get back to you tonight after work

PS: The Intel 82567LM-3 is the Ethernet network adapter, not the Wi-Fi adapter.

802.11ac 1200m adapter is that the chip set

If it is a Realteck chipset, then the code will begin RTL. some of the most common problem sets are RTL8189ES and the 8189EC but any of the newer chip sets can also be problematic

if the device is onboard, run:
lspci |grep Realtek
and post back here.
if it is usb,Plug in your device in and run
lsusb | grep Realtek
look for the wireless adapter and post back here.
many Realtek devices that fail to properly load Kernel modules (drivers) have a fix somewhere on git-hub. One step at a time though. Let’s find out what device we are dealing with, before we start compiling kernel mods… :wink:

1 Like

alternatively run inxi -Nn then copy/paste the result back here

I managed to solve this error by downloading a new firmware for realtek on github

Hi @Xxkushyxx

Hope you are great today.

I was having the same issue with mi WiFi adapter tp-link TL-WN821N.

On the Box for your Wifi Adapter, there is a model id, TL… something and the version. I was looking for more than 2 days at github.com by entering the model in there. Most of the steps did not work, however I was able to find one with a step by step about how to install the drivers.

My advise: Find the model, enter the id at github and try one by one checking the steps. You can find the model as well by going to the drivers cd and by going to the manufacturer web.

Hope this can help you, regards.

well on the device it says techkey-6B06 AC-1200

you mean on my wireless device i plug into my computer that’s hat it says. feeling like maybe i am not building it correctly becouse it came with the cd and it worked on windows? when i try grep Realtek i don’t find nothing

inxi -Nn just has this back Device-1: Intel 82567LM-3 Gigabit Network driver: e1000e
IF: enp0s25 state: up speed: 1000 Mbps duplex: full

weird its almost like lsusb shows nothing but my mouse keyboard and empty ports about to just nut a new one and try again do you guys have any recommendations on ones that you know are easy to plug and play or anything. thank you everyone i greatly appreciate your help.

its not showing your wi-fi at all

just been on the Shenzhen Denos website, very little technical information,
If your mini usb came with a driver disk, put it in your optical drive, and open, it should contain the required driver set, find the Linux driver click and open, it should self install

now the bad news, I have one of these cheap mini dongles [with disc] and as yet, it has never worked on any of my machines