Useless DNS addresses in resolv.conf

My /etc/resolv.confadded addresses automaticaly

nameserver fe80::1%eth0

this file will be changed to default after starting system. Local address are totally useless, that IPv6 format breaks Ruby’s resolv.rb library. Is there any thing can i do with this?
This is Debian’s feature, and i think this is silly -_-

What version of Parrot are you running?
Linux parrot 4.15.0-parrot11-amd64 #1 SMP Debian 4.15.11-1parrot11 (2018-04-05) x86_64 GNU/Linux

Configured to multiboot with other systems? (yes / no)
Yes, i am booting with Debian 9

By resolv.conf’s nature, you need to find out what the last thing that handled it was. Parrot’s default starts with several comments (as is pretty standard, it’s a courtesy for things to do such but some still don’t like anonsurf), anonsurf usually disables ipv6 and starts with - for obvious reasons (local addresses are not useless)

You may find some help here:

1 Like

also it’s that %eth0 format string that’s breaking your ruby library, ruby should handle ipv6 fine or there’d be an uproar
Have you messed with a static config in network-manager or anything?
Someone else may have a better clue, but I’d personally need a lot more information given resolv.conf’s dynamic nature

1 Like

I didn’t do any static ip configuration. I installed fresh Parrot 3.11 and I have this problem. I did not have this problem before and I have no information about this problem. I will try your url and give feed back.

Can you find out the last process that handled resolv.conf , by default it was probably anonsurf… let me know. I’m not a staff member, I just want to make that clear.
If you’re trying to make permanent changes to resolv.conf the appropriate place would be /etc/resolv.conf.d/base

1 Like

I don’t know how to find process handles resolv.conf :frowning: there is no /etc/resolv.conf.d/base as well. this is a mess stuff. I can make python script to remove this string and put it to startup lol

Hi. The path of folder resov.conf.d is /etc/resolvconf/resov.conf.d/. I found a update script update.d/libc and a text file could be its regex /etc/resolvconf/interface-order. I am thinking editing interface-order can remove wrong ip addr. Thanks you all for helping me :smiley:

My stupid problem solved by disable IPv6 in network-manager. Thanks guys for helping me :smiley:

1 Like