Veil 3.0 install issues

Briefly describe your issue below:
Have tried installing veil 3.0 via git clone then follow the instructions from the git install. have received errors, see pastebin. I installed veil 3.0 on my Kali live, cant seem to get it to work on parrot.
i use root terminal and execute the folling commands
-apt-get update
-apt-get dist-upgrade
-cd /opt/
-git clone (paste url here)
-cd Veil
-./config/ --force --silent

runs - i see errors - finshes

-./ and this eror pops up

[!] ERROR #2-3: Can’t find the WINE profile for Python v3.4 (/var/lib/veil/wine//drive_c/Python34/python.exe). Run: /opt/Veil/config/ --force --silent

have trying running the errors fix “/opt/Veil etc.” in all forms of terminal root and standard, with and without sudo. still no go and i am pretty lost.
Any help would be greatly appreciated.


What version of Parrot are you running? (include version, edition, and architecture)
PRETTY_NAME=“Parrot GNU/Linux 4.0-beta”
NAME=“Parrot GNU/Linux”

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
debian standard
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
many but none of them have any detail nor do they make sense, so they are never answered by the developer
If there are any error messages or relevant logs, post them below:
<script src=""></script>

try sudo apt install wine32 and see if it installs it correctly

i dont have a solution for you but an advice, dont use veil, fatrat, msfpc and other bad scripts of that kind, msfvenom is plenty enough, with some tweak and encoding + iterations you can get a fud

on the other hand, veil and fatrat install ton of useless things, might throw many errors, and fail at installation, as for shellter, though it is good its limited to 32bits and windows, so even if you pay for the premium shellter its still not practical, and msfpc is just to generate basic msfvenom payload

also veil and fatrat are detected by most av, shellter only by kapersky(unless you tweak it yourself)

How about sudo apt install veil?
Have you installed wine32?
Have you installed python in wine manually?
Have you try installing without firejail?

it says “wine32:i386 is already the newest version”

also i was only using veil because the course im learning throuh uses it, but with all the install problems i have had, i am probably going to just stick with venom

im told installing veil through apt is not proper to the software, the developer often states to install throuhg git only. but i will give it a shot.
yes, wine32 is installed
as far as the last 2 i am not sure how to accomplish that.

for installing python inside wine, you should donwload python setup file (exe) and run wine python-setup.exe. kinda like that.
if you still have this problem, run sudo apt remove firejail and try. but this is not recommended. Firejail is parrot os’s sandbox by default.
if you are searching bypassing AV solution, Parrot is having hyperion encrypter. you can find it in /usr/share/windows-binaries/. But it can not run under firejail sandbox.
Search Phantom-Evasion on github. This is a good bypassing AV solution too.

the guy who wrote phantom-evasion also slipped a crypto miner inside it as a “donation” feature ha
i certainly dont recommend it even if it gives fud, and anyway its just a script so one can do it itself and stick with the payload as long as it works (usually its one time use)

Oh i didn’t know it. Thanks @coyik. I used his script when it was 1.0 version and it worked very well.
In my opinion, shellter is the best FUD solution. I tested veil framework and i had bad result.

yeah shellter can be undetected by av with some tweaks, but its limitation to 32bits executable made me not use it anymore(even with premiums its limited to dll and exe only), i like msfvenoms flexibility, you can do wonder with it and its preinstalled with metasploit so no wine32 to download or things like that, which is handy when having low internet speed