Virtualbox USB Issues

Briefly describe your issue below:
I have been using parrot without issue for a while, First off thanks much to the devs, this is by very far way my Preferred OS!

Although recently I ran into an issue after installing virtualbox. First installed virtualbox and VM vurtialbox Extention pack, I then started my VM’s (normally boot on another computer running ubuntu) with attached usb devices (To the vm through virtualbox vm settings) and also with shared folders normally on my other computer I have no issues and can use it well with no su needed. When trying to start the virtualmachines on the parrot PC everything worked perfect up until the point where I tried to add shared folders and/or USB devices. Shared clipbord option has no issues and works well though when trying to use shared folders or usb devices tjey do not show up. I add a shared folder attempt to mount it and it simply wont even show up in “/media” folder as it should also when trying to add usb devices attached to the VM it doesnt show any devices that I can attach to the VM it is just an epty dropdown list in virtualbox. I tried running virtualbox as superuser/root and what I found is that I am then able to use,see, and attach any usb devices I need as I should be and they work in that case but I am pretty sure that its not a good idea to run virtualbox as root as it then gives root access to VM’S. My guess is maybe it has something to do with firejail or something like it blocking access but no matter what I still cant get shared folder access on the vm’s? Any and all solutions or help are greatly appreciated thanks for your time!


What version of Parrot are you running? (include version, edition, and architecture)
(Newest) 4.2.2 (recent reinstall with all updates to today) security
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard
Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Also I just tested drag and drop and it works both way when running virtualbox with or without sudo, this is only extention feature of the 3 listed in this thread that seems like it is working correctly as it should with no modifications or elevated permissions.

Im really not sure if this is a peoblem with VB or parrot to be honest, i dont use virtualbox enough to know its ins and outs well enought yet. It sounds to me you like to use nesting for security purposes like we have been discussing in the Whonix-Parrot collaboration exploratory thread!

Should I also ask and talk about this in there? it does seem whonix and parrot combo would be amazing both working togeather as well as possibly fully sandboxed vm’s maybe it could help block certian vm exploits/vulnerabilities?? And Yes I am trying to keep firejail running and have additions options work correctly too, it would be nice to keep everything possible sandboxed for extra measure. And I am trying to see how to do it without running as root. Main issue I am having at the moment is seeing usb devices while not under sudo previlages is not working correctly. Shared folders either but thats not nearly as important I could just run a local ftp server to solve that.

Any other input or help is also appreciated if anyone has any ideas or other possible options.

Hi all!

I had the same issue and when running on Parrot 4.5.1 and fixed the issue by adding my user account to vboxusers. Please not the ‘s’ because I’ve seen some solutions using just vboxuser with no ‘s’.

Before I did this I couldn’t see any of my USB devices even after installing the guest additions. Run the command below then reboot.

sudo adduser myuseraccount vboxusers

Thanks to all who are developing ParrotOS! It’s my main OS now and I’m now promoting it over Kali.

1 Like