VM ParrotOS not recognize WiFi

Briefly describe your issue below:
As stated in the topic, I have tried many different configurations of the VM Network mode and nothing seems to recognize the USB 2.0 added Antennae (its a generic antenna and host machine has it listed as a Ralink RT2870/RT3070). I know can be set to receive since I use it for sniffing my home networks but I can’t even get that far. I can do a full install and get it to recognize but that kind of defeats the purpose of having a Live version ready to go on a drive. This has to be something simple that I’m overlooking. I’ve added guest additions as well.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) 4.6 AMD64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) LiveUSB (128GB MicroSD on a USB PenDrive)

Configured to multiboot with other systems? (yes / no) No, Virtual Machine.

List your networking hardware (make, model, firmware version):
Qualcomm Atheros QCA9377
Ralink 2870/3070

If there are any similar issues or solutions, link to them below:
I’ve found many “solutions” via looking up Kali Linux VM install / WiFi but none of those have worked for me. The machine will not recognize the USB or the built-in WiFi on either ParrotOS or Kali

If there are any error messages or relevant logs, post them below:

what kind of VM software are you using (VMware / Virtualbox / KVM)
and dit the software give any errors when you enabled USB

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.