VPN will not connect after last update

Briefly describe your issue below:

VPN will not connect after last update.
It says vpn connection failed because it timed out, and took to long.
It was fine before the update, and was connecting instantly.

Can anyone help, i did a fresh install and update , i get still the same error.

What version of Parrot are you running? (include version, edition, and architecture)

I have the lateste 4.2.2 and updated it.

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)


Configured to multiboot with other systems? (yes / no)


If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

We are officially on 4.3 as of this evening (morning actually but i think there was a very minor bug that had to be fixed at the last minute and maybe its reversed for you if youre not in the same location i suppose haha) but i wouldnt immediately suspect that as the cause if your issue, i would investigate what package and network manager/protocal is handeling your bpn configuration first. What protocol and how did you set it up?

i got a pop up that there are updates available, went to control center and opened synaptic package manager to update.
i have installed:

openvpn 2.4.6-1
network manager 1.14.4-2
network manager gnome 1.8.18-2
network manager openvpn 1.8.8-1
network manager openvpn gnome 1.8.8-1

these two i have removed after the update because i thought i did not deed.
but i still get the same problem when they also are installed.:

network manager openconnect 1.2.4-1.1
network manager openconnect gnome 1.2.4-1.1

and also these were not installed before the update and now they are:

wireguard dkms
wireguard tools

do i need to remove or install anything else?

You actually need the network manager openvpn package i believe openconnect is different than openvpn.