Webcam not detected

Hello everyone :sunny:

After 20 years on Linux (Mandriva, Xubuntu, Ubuntu, Mint), I have just switched to Parrot Sec and I am delighted. Thank you for this little gem of confidentiality and ergonomics.

The only downside is that when I wanted to do a customer training session by video, I realised that my webcam was not detected.

What can I do?

Here is my configuration:

  • Parrot Sec Home edition 5.0 (Electro Ara)
  • Laptop mounted

Thanks for the help :wink:

Welcome,
please run inxi --usb from terminal and paste back the report

Hi.

Thanks for the help.

Here is the result:

USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
  Device-1: 1-1:4 info: Mad Catz Catz M.M.O.TE type: Mouse,HID rev: 2.0
  Device-2: 1-8:2 info: Acer BisonCam NB Pro type: Video rev: 2.0
  Device-3: 1-14:3 info: Intel Wireless-AC 9260 Bluetooth Adapter
    type: Bluetooth rev: 2.0
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1

Erm… Acer BisonCam , never been the best option in Linux, it’s a salt and pepper job, it either works or not,
things to try,
From memory, Acer has a key combination to turn the webcam on/off, I think it’s Fn+F6 .
Make sure it’s enabled in the Bios
if you open cheese, does it work?
Drivers for this product have been in the Kernel set since around 2014, but there have been many cases across the web where they haven’t worked in recent years, try the above and I will have a word round and see if any of my associats know a working fix.

The only other suggestion that’s come beck to me, is if the first options do not work use modprobe to re-install kernel drivers

Hi there.

No device found.

Not working, I have tried all the possible combinations and I found:

FN + F10 (with the camera icon)

Thanks for the help :sunny:

The FN+ key combination varies between makes and even models within a make. I guessed at F6 as it is fairly common, Glad you found the correct ones for your box and it is now working.