Weird Parrot Booting Issues

I dual-booted parrot with Windows and used it for some months, one day, I spam some screenshots and it’s lagging, I force reboot it and it still botting but it stopped booting at the pending screen (the screen that has the parrot logo at the middle, before the login) it showed the pre-login pending screen (the one I described above) then crashed and came to a black screen that have the SMALL repeating flashing underscore (_) , when I force shutdown it show the pre-login screen and then shutdown.
Anybody please help.
Best Regards,
A Parrot OS User

Likely your graphic driver isn’t compatible with new Kernel version. Or your parrot wasn’t upgraded correctly.
For first case, try use advanced boot option in grub, select older kernel version
For second case, try sudo parrot-upgrade

I mean I got locked out, it’s nearly the login page but it gets darker and then crashes, leaves a very small underscore (_) in the upper corner. I tried to choose another parrot version and of course, I can’t run upgrade.
Hope you can read this, thanks.
P/S: Are you Vietnamese? @dmknght (free ping)

I have an Sony Vaio from 2004 which has exactly the problem you describe.
This is what helps here:

Take a deep breath
Reboot
when the Parrot Logo screen comes up (prior to login)
start to repeatedly press the Esc key
if you are lucky after 10 to 50 presses a terminal screen may come up
if this screen comes up do not press esc key anymore ( or you need to restart again)
the terminal will show a message complaining about tomoyo
If you reach this screen there will be a prompt , there you write :
disable then press enter
I write it 10 to 20 times then the system starts to boot fine.

Yes, I tried all else parrot update etc etc . Nothing else works on this system
If you only reach the flashing cursor you need to reboot.

No guarantees , but it works here everytime …

Some specific hardware could have specific problems. Because Parrot is a rolling distro, so update could change the hardware support a lot.

The last time we received bug report about this package was 2 years ago. This is kinda weird.

I have 4 parrots running here and only the old Sony has this issue . It has a Intel Core 2 Duo T9400 Cpu and ATI Mobility HD Radeon HD 3470 Graphics , 4GB Ram . The booting process takes some time but once it runs everthing is perfect.

uname -a
Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux

eh i tried to press esc like you when it pre-login but it shows some weird logs