WiFi Applet


So I’ve recently just installed Parrot Security OS onto my Dell XPS 13 9370 however I’m having trouble with seting up/connecting to WiFI, there doesn’t seem to be an applet in the top right of the desktop to be able to view available networks and connect to them. Going into the control panel its the same thing and I’m unable to scan for networks and connect to them. I’ve got around it by manually entering in AP’s SSID and PSK but for portability I’d rather not do that for every AP.

If anyone could give me a hand that would be great, if you require more information that can also be arranged!


What version of Parrot are you running? (include version, edition, and architecture)
Parrot Security 4.4

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Funny one eh. This could be a pain.

Does iwlist scan work?
ifconfig should list your network interfaces, one will probably be ‘wlan0’.
Then iwlist wlan0 scan will list access points (disconnect from any first).

Apologies for the late response, just recently tried installing it again and the same issue has occured.

Those commands all work, returns nearby SSIDs which I can connect to, wlan0 is shown in my ifconfig

run the following commands

nmcli devices wifi list

if it gives you a list of nearby wireless networks, then run the following

sudo systemctl enable networkmanager

reboot and see if the applet shows up

Didn’t work. iwlist wlan0 scan properly scans nearby networks. I just wanna connect to them haha.

OKay so it looks like if i type nm-applet it works however I can barely see it in the top right of parrot os. All the panel applets/icons seem to be really pushed together. I’ve got a high dpi screen (4k resolution)

I believe this is an issue with HighDPI scaling? It’s just an issue with the notification area applet as far as I can tell? Any way to resolve this?

maybe, try going to the panel “System”, “Look and Feel”, “Mate Tweak”, and in the “Windows” tab, change the HiDPI scaling to what is available.

So theres only two options, Regular which makes everything really zoomed out and near impossible to see anything without being 2 inches from the screen; however on this mode the applets are fine in the top right and I can see them all properly. In the HighDPI mode the screen is fine and as expected bu applets are bunched together and not really visible.

have you tried right-cliking on the top panel and choosing “Reset panel” ?
i can’t help you much because i never encountered this problem before

Yep tried that too. Goes back to how it is. Seems to be an issue with HighDPI scaling

maybe the Mate-Desktop community can help you with this ? they have a forum and IRC channel