Wifi delayed start

System Info
*Parrot GNU/Linux 4.10
*Kernel version: Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux
*Desktop Environment: Mate Security
*How did you create USB: Rufus DD mode (same usb I used for successful install on same laptop previously
*How did you install OS? Debian installer
*Hardware information: Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Did you try searching info about this issue on search engine?
Search wasn’t returning same issue I’m experiencing

I installed Parrot OS about a month and a half ago and it was working well. Last night I started having an issue with ParrotOS after installing QUME.

The issue is problems with WIFI connectivity.

The WIFI intermittently shows available networks. Sometimes available networks are present, other times it just shows the options “create a network” and “connect to a VPN” and no wireless networks are displayed (but there are several wireless networks actually in range).

When wifi networks disappear, my blutooth still works and I believe the hardware for the two are integrated.

After the install of QUME last night and noticing the problem, I uninstalled QUME and dependency changes, but it didn’t correct it.

I did a clean install with the same flash drive I did the initial install with the beginning of December. I did all updates, and installed a few things that I already had on my previous install:
Protonvpn-cli (although I don’t know that it was the exact same version this time. I had just the command line protonvpn via openvpn, now I think protonvpn is using a beta app things, but I think I only installed the command line version because sudo protonvpn-gui doesn’t do anything.

It worked initially, but then when I turned the PC off and restarted, the available networks were gone again. Then, about 10 minutes later they showed up on their own and connected automatically.

I decided to try something and restarted the PC. The available networks don’t show for about 5 to 10 minutes after the restart, then turn right on and auto connect.

Upon booting, before the wifi decides to enable, if I hit the wifi button on the keyboard once it displays a message that wifi is disabled, and if I hit it again it turns on right away with all available networks so I don’t have to wait 10 minutes.

At first I thought it was ProtonVPN, but after uninstalling it on the first ParrotOS install the problem persisted .

I’m new to linux, but in Win 10 I’ve edited registry values that set the start behavior of processes so that they start with the OS or delayed. I’m wondering if there is an equivalent in ParrotOS or something that got changed around with an update or if this is a common and known issue?

Your card was working fine for a while on Linux? Did this change after an upgrade?

Any clues in the logs?

Take a look at the output of:

sudo dmesg

and see if connection problems show up around the time you have issues (don’t paste entire log as reply, but sharing relevant information can help).

Right to Privacy, thanks for the response. I wasn’t seeing anything in dmesg, but I managed to find the problem.

ProtonVPN has a Kill switch that previously was set to still allow traffic to and from the LAN if the connection was dropped, but when I did a reinstall the kill switch was set to block to and from the LAN. After changing it back to the initial option my WIFI immediately connects upon startup.

Now that I know the problem I put it back to block to and from the LAN, and have to un-enable and re-enable my wifi to get it to connect. It only takes two clicks of a keyboard button, but I like the idea of having the kill switch enabled from the start.

Thank you

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.