Wifi don't work in my Dell Latitude D620

– Please Write here your help request, –

—Hello there. Recently I installed Parrot on a Dell Latitude D620 and the system booted fine. But when I look, the wifi card is not working. I am using a Dell Wireless 1409 card in here. Seems like Parrot doesn’t detect the hardware. Would be much help if I can get the drivers.

Any help would be appreciated

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):

4.11

  • Kernel version (if you are not aware of it, open terminal and type uname -r):
    5.10.0-6parrot1-amd64

  • Logs/Terminal output (use pastebin or similar services):
    None

  • Screenshots:
    None

Update: I just lspci and lspci | grep Network in my terminal and it seems that Parrot detected my Wifi card properly so I’m thinking that this is a driver problem that I’m having rn.

Hi, if necessary, check from the website of the manufacturer of your wifi card if there are drivers available and install them manually. Take a look here: bcm43xx - Debian Wiki

Hello, I have successfully enabled the wifi using the b43 module i loaded with sudo modprobe b43 which is very nice. But now I’m stuck with having to load the module everytime at startup which is a bit of an inconvenience. Is there anyway to load the module automatically at startup? I have done some of my own research on how to do this and i stumbled upon someone in an other Linux forum saying that I have to edit the /etc/modules to add my module, in which i added b43 to the file then sudo depmod -a in the terminal. I followed this step and unfortunately it didn’t work.

Is there a specific way to do so in Parrot?

Hi, you must to enable it, to do this you need to create a module_name.conf file (it is important the .conf extension) inside the /etc/modules-load.d/ folder.

In your case you could call it “bcm4311.conf” (or similar) and insert the module to load.

Reboot and let me know.

I have followed what you have written here but it didn’t work too. I created the bcm4311.conf file at the correct directory and I have inserted the b43 entry inside the conf file. Rebooted and it didn’t work. I lsmod in the terminal after i loaded the b43 module with modprobe and i noticed that some modules were used by b43. I tried adding them to the entry but it didn’t work too.

Perhaps maybe there was a working way? Or am I doing it wrong…

Try putting b43 on modules.conf inside etc.

Same, doesn’t work :frowning:

Weird, because it works exactly the same as for Debian. After putting the module on modules.conf, try updating initramfs with the update-initramfs -u command.

I leave you some links that could be more useful to you:

https://www.freedesktop.org/software/systemd/man/systemd-modules-load.service.html#

The same case is mine… is it solved???

lspci | grep Network
0000:00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)

lspci | grep Network
0000:00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)

Anybody can help me??

You have to download the driver for that wifi card (Intel AX201) and that’s it.

I did it but no use

Hi, I don’t know if this may help
I recently installed Parrot Home on my old del 1540, [also has bcm43* Wi-Fi]
my Wi-Fi also would not connect, I ran inxi, this showed the correct kernel driver was installed,
after a few minutes messing around, I found it loaded with a “hard block”, using the FN + Fkey to turn on the Wi-Fi it worked just fine