Wifi Driver for (Wfi 6 AX201)

Hi there,
I was using Parrot Sec on my desktop with a wifi adapter, wifi was working fine. Now I bought a new laptop with configuration:
HP ProBook 480 G8
The problem is my internal wifi card has no drivers!!
My WiFi card is Wifi 6 AX201
Note when the Wifi adapter is plugged in, Wifi starts working automatically without any problem
I tried downloading the drivers from intel’s website Copy/Paste into lib/firmware , rebooted but still not working.
I tried lwwifi from github but still no use.
One more thing, Wifi is also showing in my BIOS but not in Parrot OS

  • Parrot version in use 5.0 (LTS):

  • Kernel version (5.14.0-9parrot1-amd64):

Result from lspci and inxi -N:

Working - not working…!
When does it not work?

My internal wifi card is not working (was working on windows ) but when i plug a USB (adapter) it starts to work without any problem

Hello, The problem is obvious: you are missing the drivers for your internal wifi card (intel ax201), you can find them here: Linux* Support for Intel® Wireless Adapters

hey, I have the same issue. now I have downloaded the drivers according to my model but what to do after that ??
Can you guide me, please??

It’s written inside that webpage: download the .tgz file for your wifi card (ax201), kernel 5.2+, and then copy the files extracted into /lib/firmware. Reboot. Have fun.

The whole folder or just the files of the folder??
Please guide me

Put the files of the .tgz folder inside the firmware folder (which is located inside /lib).

1 Like

Still not working sir?
But I did a inxi -N again it resulted:

inxi -N
Network: Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168

But after pluging the wifi adapter in it became

inxi -N
Network: Device-1: Intel Wi-Fi 6 AX201 driver: N/A
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
Device-3: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u

I am so upset!!

Before you get angry think about it lol, why did you add another wifi adapter? As you saw from inxi, the driver was loaded: “Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi

Remove the adapter, and you should see the wifi icon active, ready for you to select a network to connect to.

That is the main problem after I rebooted my laptop the driver was there but it wasn’t connecting to the wifi not even showing the wifi icon (Only showing the Ethernet Icon ). Help me please I am stuck at this for 5 Days (Since I bought the Laptop)…

Well you cannot compare windows here.
AFAIK the latest kernel doesn’t support some Wi-Fi card, you might get to know with a Google search
And one of our users said this on telegram group…

Try This It’s Worked For Me
1.go to BIOS setting and navigate to BOOT menu
2.set boot mode Legacy support and boot priority as UEFI firs
3.Thinks to ENABLE
Fast boot -enable
PXE boot to LAN -enable
IPV4 PXE LAN first -enable

4.In EFI priority Setting,use F6 or f5 to make it
move EFI PXE Network (xx-xx-xx-xx-xx-xx) to first
move your to second

thats all you do…

5.Don’t forget to save changes,Press F10 and select Yes
your machine will boot with “Checking media_”

explanation: The bios update only support Windows softwares.By making EFI PXE first will wake the wifi before boot,So, the linux os can easily identify the Pcie WLAN card and it can be claimmed as a device in linux

1 Like

Is this a vm?

No sir, Parrot always as main OS :heart:

Ok, open a terminal, and type sudo update-initramfs -u, then reboot.

I did this @danterolle but still no use

I noted that my bluetooth is working fine (just telling) any connection between BT and WIFI??
and one more thing :
Just like @Hashir_Siddiqui at the output of inxi -N it is showing the driver named iwiwifi (when adapter is not plugged in) but the driver is still not working ???

I also tried bios setting method but it also not worked for me !!! :frowning:

Any idea what’s going on???

I did as @danterolle said:

sudo update-initramfs -u

Nothing Changed … Sir

Sir Bluetooth is working fine if there is a connection between the wifi card and Bluetooth… Just a Thought!!

Does parrot OS support newer (11 gen) hardware
just asking

Of course.