Wifi not showing

parrot

(Arjun) #1

Hi guys.i am using parrot sec on macbook pro in vmware fusion.
So everything is good but in parrot sec it doesn’t showing the wifi connections.Actually it showing the wifi but not showing the networks like wpa2 or any networks.
Can anyone help me to see the networks in parrot sec.
thank you.41%20AM


(Keyboard) #2

You are not seeing the networks because of the networking options of vmware. You should check the documentation of vmware and choose a different option (vmware got options to directly plug usb devices inside the virtual machine without passing directly through the host) after reading the options you have.


(Arjun) #3

Then how can i hack the wireless devices using parrot sec.
If it shows the wireless networks only i can able to hack using fluxion or aircrack.
How to get that?


(Keyboard) #4

Well first you must check the options of vmware and check the apropiate one.
When you get with the appropiate one it should be as easy as clicking in ‘attach new usb device’ choose the router/antenna and it should detect it as if it was your normal operative system (will work in monitor mode too guaranteed).
Unless you already did that (but I don’t see why it should not work)


#5

you can hack once you fix the network problem in vmware as UserOfMouse has told you twice
use a BRIDGED connection in vmware, you need a compatible wireless adapter to go into monitor mode


(Arjun) #6

How to get compitable wireless adapter


#7

Buy one :slight_smile:

Tp-Link TL-WN722N V1 is the best
( the version number is important !!! )


(Arjun) #8

34%20AM
How to get regular wifi connections here.
Help me


#9

Check your wifi driver, probably yours didnt installed.


(Arjun) #10

Then how to install that. i am asking about wpa2 networks. for that how to install the wifi driver?


#11

Read the whole link
What wifi card are you using ?


#12

I have this same problem I have tried everything possible but no WiFi signal or anything showing but my ethernet is working fine once I connect with cable . Can anyone please help plus when I run ifcong no iwlan showing just Eth. Thanks if anyone can help