Wifi option not available

Hello there. I managed to install parrot os on my hdd apart from the other os I have on SSD, without creating a dual boot.
But the wifi adapter not available or not working properly on my device. I have intel AC 7260 dual band wifi adapter on my laptop.

I’ve been trying for hours multiple solutions I found online but with not success. Below I will put some information that may give you a hint where the problem stands.

Blockquote
iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

lspci
3e:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)

On my /lib/firmware folder I had 2 files
ls /lib/firmware | grep 7260
iwlwifi-7260-14.ucode //This file was added by me from a file I download from intel site.
iwlwifi-7260-17.ucode
iwlwifi-7260-9.ucode

Also sudo modprobe iwlwifi does not return anything but when I tried to run sudo modprobe -r iwlwifi It said it is in use.

Thank you in advace!! :slight_smile:

1 Like

hello
what is your parrot version??

Maybe

1-sudo parrot-upgrade && sudo apt autoremove
(reboot)
2-see if solved
3-(if no)sudo purge firmware-iwlwifi firmware-intelwimax firmware-misc-nonfree && sudo apt autoremove && sudo apt install firmware-iwlwifi && sudo apt firmware-intelwimax && firmware-misc-nonfree
4-reboot
5-see if solved

otherwise gives the return of the rfkill list all command

My parrot os version is 4.10

rfkill return only bluetooth device wich is only soft blocked.

nope that didn’t work as well.
maybe this may help, when i run inxi -N
Network:
Device-1: Intel Ethernet I217-LM driver: e1000e
Device-2: Intel Wireless 7260 driver: iwlwifi

this is the output.

ok ok show me the rfkill return thanks ! and the return of this command by plugging your wifi adapter
dmesg | grep wlp

How does it look from your side?

desole je suis francais lol
then try
sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
unplug and plug and
sudo iwconfig
?

sudo iwconfig should give you something like

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"********"
Mode:Managed Frequency:2.462 GHz Access Point: ************
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=70/70 Signal level=-28 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:28 Missed beacon:0

wlx00c0caaa3359 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

this is my return order we can see that my wifi adapter wlx00c0caaa3359 is well recognized but is not connected to the internet just go to your taskbar on wifi is connect you

Rfkill returns only the bluetooth device.
Its on a laptop so I can only turn off by button
dmesg | grep wlp returns nothing but need to be run as root.
Then sudo modprobe -r cant be run since it says
FATAL: Module iwlwifi is in use

try sudo modprobe -rv iwlmvm
show me the return of sudo iwconfig

Sudo modprobe -rv iwlmvm
Rmmod iwlmvm
Rmmod mac80211
Rmmod iwlwifi
librac4

Then sudo iwconfig
lo no wireless extensions.
eth0 no wireless extensions.

ok when you entered the command sudo iwconfig your adapter is not connected?

It is connected since its a laptop and it works fine in my other os

https://wiki.debian.org/iwlwifi#Installation

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.