Wifi problem in parrot os

iam having wifi problem in my parrot os 4.7 ,i have tried many ways but no use
~lshw


can anyone please help ?

are you on a virtual box or installed as a main Os?
if on a virtual-box u need an external wifi adaptor.
if as main-Os try the following:
sudo airmon-ng check kill
sudo service network-manager restart
sudo ifconfig (wlan-card) down
sudo ifconfig (wlan-card) up

I have installed… Main os… tried… all the commands but no use

try edit /etc/NetworkManager/NetworkManager.conf and change the managed=false to true
if nothing happen try read this may be it will be of help ,also try read via the README.md in github https://github.com/lwfinger/rtlwifi_new thank you.
https://techcatalystblog.wordpress.com/2016/07/12/rtl8723be-wifi-fix-for-linux/

The firmware shows as “firmware=N/A”, that shouldn’t be a value of not applicable because If it didn’t need firmware it wouldn’t show that as an information element at all. Search for the firmware bin blob for the driver. I suggest github.

my drivers not listed on the url my drivers are rtl8822be can you please help?

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.