WiFi problem


(Gaurav Kumar Sharma) #1

I freshly installed the parrot os in my HP laptop which was running on Windows 10 before. But i can’t find any options to enable wifi and there is no option fo it, i can only find wired connections in top right button, please help me to fix this issue.


What version of Parrot are you running?
Version -4.4
Architecture - x86-64
4.18.0-parrot20-amd64

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Amzker Pro Hacker) #2

This is real bug :clap:LOL
Mate try to open setting / control

And see if not
Can you really have driver (if using external hardware for WiFi)
Or inbuilt wifi adaptor

If really have plz open
airgeddon (weird but wanted to check that scan or not
Possible graphic error or Mate DE error as hope)
After opening airgeddon you get wireless adaptor option
If yes then send screenshot so we see which hardware it is


(Gaurav Kumar Sharma) #3

i can’t find airgeddon


(Amzker Pro Hacker) #4

It’s command
You also find in
Application/parrot/wireless/airgeddon


(Gaurav Kumar Sharma) #5

i get this when i run sudo lshw - C network

[✗]─[gaurav@parrot]─[~]
└──╼ $sudo lshw -C network
[sudo] password for gaurav:
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 15
serial: ac:e2:d3:ce:11:c5
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:16 ioport:4000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
*-network UNCLAIMED
description: Network controller
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: ioport:3000(size=256) memory:b1000000-b100ffff
*-network
description: Ethernet interface
physical id: 3
bus info: usb@1:2
logical name: usb0
serial: 02:97:5e:09:db:88
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device link=yes multicast=yes
┌─[gaurav@parrot]─[~]
└──╼ $


(Amzker Pro Hacker) #6

rfkill unblock wifi
Ifconfig wlan0 up
nmcli n on
iwconfig wlan0 power on
iwconfig wlan0 txpower 20
service network-manager start


(Amzker Pro Hacker) #7

If not work install old version


(Gaurav Kumar Sharma) #8

[gaurav@parrot]─[~]
└──╼ $rfkill unblock wifi
bash: rfkill: command not found


(Gaurav Kumar Sharma) #9

Isn’t there any other option?


(Amzker Pro Hacker) #10

Devs Working so they are bisy
And i am noob , so i have no idea possible there is other way
Can you try airgeddon
I just wanted to know that hardware mounted or not
By scan it via script
In terminal type
airgeddon or wifite
If they show you your woreless hardware (and best is if wifite is start then it is mounted just not showing option in MATE DE)
service network-manager restart
nmcli networking on


(Gaurav Kumar Sharma) #11

$airgeddon
bash: airgeddon: command not found
I get this


(Amzker Pro Hacker) #12

Follow last 2 lines
Service vali bhai


(Gaurav Kumar Sharma) #13

han maine last two commands run ki hai
service network-manager restart
nmcli networking on

lekin phir bhi kuch nai hua


(Amzker Pro Hacker) #14

Re install
Hope work
But can it working on windows?
If yes plz reinstall Old version of Parrot


#15

First, sory for my bad english. I am having problem with wifi adapter and network manager. Every time i run “Fern wifi cracker " and select interface” wlan0 " - it kill my network manager,and program cant detect any network… Restart in terminal dont make diference. Only restart pc. If it is any cure for this , i am listening. Thanks.

Parrot Security 4.4 -32bit


(Ripper) #16

maybe type
airmon-ng interface name stop
and
service name1 restart

interface: wlan0 , wlan0mon & wlan1 (which you see on your screen)
name1 = network-manager


(Ripper) #17

maybe type
ip a
&
airmon-ng
airmon-ng interface_name start or airmon-ng start interface_name
airodump-ng interface_name
if you see any network… it means your wifi work…
and try to downgrade your Parrot… if wifi not work properly…


#18

My Wifi disappears every time I reboot. Only turn off, turn on works.


(Nico Paul) #19

its in Monitor mode vs Managed.


#20

@b1ttu
@gustavo7845

You could also just use the hardware lister application you find under menu>system tools…it shows all the various functional components (pci, net devices/interfaces, cpu, bios) with information on each. If the wireless device is installed it should appear there with a note on saying “disabled”, if you still can’t find it you should make sure the device is properly installed.

Also I notice @gustavo7845 I notice the second of the network devices your lshw shows is an ethernet interface though its logical name shows it is connect by usb so in your commands you might try substuting “usb0” for “wlan(*)”. I assuming there is a usb device in the picture? yes?

We could and see of a OS service problem with “systemctl --failed” and “dmesg” (need root priveledge on both)