Wifite monitor mode failed in parrot os

Hi, I’am a new user here, deleted kali and installed parrot os

all right with install, parrot-upgrade and update, but:

when I want to use wifite, monitor mode dosn’t work. the same thing with airmon-ng…is a correct command and I do check kill and wlan up and down and google solutions. but in iwconfig the wlan0 no changing in mode is fixed with manage, after searching, I think the problem is missing a drive or something like thise. I don’t know what driver can I install…
so please who have any idea can help me

PRETTY_NAME=“Parrot GNU/Linux 4.8”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.8”
VERSION_ID=“4.8”
HOME_URL=“https://www.parrotlinux.org/
SUPPORT_URL=“https://community.parrotlinux.org/
BUG_REPORT_URL=“https://nest.parrot.sh/

wifite::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

. .
.´ · . . · . wifite2 2.5.2 : : : (¯) : : : a wireless auditor by @derv82 . · /¯\ ´ · .´ maintained by kimocoder /¯¯¯\ ´ https://github.com/kimocoder/wifite2

[!] Conflicting processes: wpa_supplicant (PID 642)
[!] If you have problems: kill -9 PID or re-run wifite with --kill

Interface   PHY   Driver              Chipset                                                                                      

  1. wlan0 phy0 wl Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY (rev 01)

[+] enabling monitor mode on wlan0… failed
failed

[!] Error: Cannot find any interfaces in monitor mode

[!] Full stack trace below

[!] Traceback (most recent call last):
[!] File “/usr/lib/python3/dist-packages/wifite/main.py”, line 97, in entry_point
[!] wifite.start()
[!] File “/usr/lib/python3/dist-packages/wifite/main.py”, line 50, in start
[!] Configuration.get_monitor_mode_interface()
[!] File “/usr/lib/python3/dist-packages/wifite/config.py”, line 163, in get_monitor_mode_interface
[!] cls.interface = Airmon.ask()
[!] File “/usr/lib/python3/dist-packages/wifite/tools/airmon.py”, line 330, in ask
[!] iface.interface = Airmon.start(iface)
[!] File “/usr/lib/python3/dist-packages/wifite/tools/airmon.py”, line 204, in start
[!] raise Exception(‘Cannot find any interfaces in monitor mode’)
[!] Exception: Cannot find any interfaces in monitor mode

[!] Exiting

airmon-ng:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
┌─[root@parrot]─[/usr/lib/python3/dist-packages/wifite]
└──╼ #airmon-ng check kill

┌─[root@parrot]─[/usr/lib/python3/dist-packages/wifite]
└──╼ #airmon-ng start wlan0

PHY Interface Driver Chipset

phy0 wlan0 wl Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY (rev 01)

	(experimental wl monitor mode vif already enabled for [phy0]wlan0 on [phy0]prism0)

┌─[root@parrot]─[/usr/lib/python3/dist-packages/wifite]
└──╼ #iwconfig
wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=200 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

prism0 no wireless extensions.

lo no wireless extensions.

eth0 no wireless extensions.

┌─[root@parrot]─[/usr/lib/python3/dist-packages/wifite]
└──╼ #

Briefly describe your issue below:

What version of Parrot are you running? (include ersion (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Are you sure your card supports monitor mode?

1 Like

yes in kali linux wase work normal, after install parrot os doesn’t work

yes i-m sure

TRY This command

# ifconfig <interface> down

# iwconfig <interface> mode monitor

# ifconfig <interface> up

# iwconfig <interface>

This should turn on monitor mode on the interface

1 Like

Have you tried selecting the prism0 device I see listed after iwconfig? This is device to be used for monitor mode for some broadcoms.

this is an old command, I found it in google before comming here, but doesn’t work:

┌─[root@parrot]─[/home/rd]
└──╼ #iwconfig wlan0 mode monitor
Error for wireless request “Set Mode” (8B06) :
SET failed on device wlan0 ; Operation not supported.
┌─[✗]─[root@parrot]─[/home/rd]

yes its work with airodump-ng, but wifite monitor mode still failed.

Are you using the same Wi-Fi driver you used on Kali? If yes is it supported in the kernel drivers or you installed it manually from a different source?

1 Like

I deleted kali os from pc, but still have it in usb, monitor working with usb live mode, can I see the name of driver by usb using live mode kali. to install it in my parrot.

I have seen it : kali wifi driver was b43, and my parrot is wl, now i just want to know how to install b43, like that or no ?

Okay make sure you get the name of the driver by using the command below:
lspci | egrep -i --color 'network|ethernet'
because it should be something much longer than b34!
then try to check compatible drivers from debian packages website as both Kali and Parrot OS are Debain based anyway so you will find your driver away or another.

Here are two resources that may help you and try to dig deeper on Google I faced much harder problem with my Wi-Fi driver and found someone who developed a driver on GitHub and that saved my life.
https://www.debian.org/distrib/packages
http://forums.debian.net/

Just remember to use the command above to get the appropriate Wi-Fi card name first.

1 Like

thank you for your help friend and so much, but I did it now:
do you know, I have been searched in google, and found the solution.
I will put all details how I did it :
this solution is for all debian distro…
Supported Broadcom wireless network cards:
BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-, BCM43228-, BCM4331-, BCM4360-, and BCM4352- lspci -nn | grep Network

sudo apt-get install wireless-tools
sudo apt-get install network-manager-gnome
sudo apt-get install wpasupplicant

sudo nano /etc/apt/sources.list
(main contrib non-free)

sudo apt-get update

sudo apt-get dist-upgrade

reboot the computer

sudo apt-get install linux-image-$(uname -r|sed ‘s,[^-]-[^-]-,’) linux-headers-$(uname -r|sed ‘s,[^-]-[^-]-,’) broadcom-sta-dkms

sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

sudo modprobe wl

If you get frequent disconnections, it can be fixed with this command:
iwconfig wlan0 power off

you can see all steps above in this video : https://www.youtube.com/watch?v=JW0f3NOjWys

after get all steps above and restart, if wifi driver didn’t change follow these below :
To unload all known drivers (you can pick only one command, if you know which driver is in use) perform:

1:modprobe -r b43 bcma
2:modprobe -r brcmsmac bcma
3:modprobe -r wl
To load specific driver use one of the following commands :

modprobe b43
modprobe brcmsmac
modprobe wl

boom done…
now driver wl chnaged with b43—> that with it can monitor mode work good
this solution for anyone will have this problem.

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.