Windows not hibernating in dual boot(Win 10+ParrotSec 4.10)

I am facing problem with my dual boot setup (windows 10 + parrot home upgraded to parrotsec 4.10). When I try to hibernate my windows, it simply doesn’t work. It used to before, even when I was using parrot 4.7. On googling for some time, I figured it has to be the active partition issue. As far as I understood the issue (and please correct me where I’m wrong), windows need it’s C partition to be marked active to be able to make use of hibernation feature. And because grub is installed in another partition (dedicated for parrot os), I can’t mark this partition as active. So maybe, one solution is to install grub in C partition, any way to do that? Or any other way to solve the issue?

have you made sure that hibernation is enabled?
powercfg/hibernate on
after that it easily hibernates
make sure you dont use the partitions mounted in the windows on linux, it may lead to data loss. and also make sure grub loads not the window boot manager because window boot manager will automatically loads the hibernated os first.