Wine Is Not Working On Parrot OS (wine32)

– Please Write here your help request, –
(I am very new to Linux & everything to do with it - It has only been a few days since I have installed Parrot)

Hi, I am trying to install a .exe file however I need wine to install it. I have installed wine and now when I use ‘wine [file_name].exe’ then I receive an error saying wine32 is missing, you should install it. It then tells me to execute “apt-get install wine32” as root so I try that command and then I receive another error. You can view it here:
I’ve tried many other commands, I’ve updated my apt and everything else.

I spent hours looking on the internet to fix this issue but I couldn’t find anything. I tried different things I saw however I still received the same errors and nothing changed.

Did you try searching this group? There appears to be an issue currently with wine32 on Parrot 5.0.

Sorry for the late reply. I haven’t been using Parrot OS since I lost the GUI. Whenever I boot it I am taken to the terminal/console. I can’t access any GUI’s at all. If I use python and import tkinter and use Tk() I an immediately given an error about a display environment variable or something. After (if) I find out how to solve this then I would try using this (could you possibly help me?). Thank you!

I can’t know what you did to fubar the desktop environment. Perhaps someone more skilled in Linux can assist.

Do you have internet access at the terminal? If so, I would try installing the Mate D.E. and see if it also pulls in all the required xorg packages as well.

sudo apt install parrot-mate

I was trying to install Wine and I saw a post on a website saying that you should use

$sudo aptitude install wine32

instead of

$sudo apt install wine32

They mentioned that it’s smarter than apt for installing packages and should be used regularly. I decided to try it and when it was installing the package it was also uninstalling many important files. It’s like deleting the System32 file on Windows. I noticed that it was uninstalling these files so I stopped it. The next time I booted my computer, there was no GUI at all (except for the loading screen) and when loaded there was only TTY1 console.

I will try what you told me now and check my os right now to answer your questions. Thanks for the help.

I have access to the internet. I was trying to install it but it cannot find the package. I believe I switched repositories and parrot-mate is not in the repository. Do you know how to switch repositories? If I can switch my repository back to the original parrot one I may be able to install the Mate D.E. unless there is something else needed to be done as many folders were uninstalled.

$sudo apt install parrot-mate

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package parrot-mate

You probably want to reinstall Parrot or some other distro that still includes wine32. To add the Parrot repositories…

sudo nano /etc/apt/sources.list.d/parrot.list


deb parrot non-free contrib main
deb parrot-security main contrib non-free
deb parrot-backports main contrib non-free
deb parrot-updates non-free contrib main

Add not to steer you away from Parrot, but if you want a pentesting distro with wine32, Kali has it.

Thank you so much! I will try this.