Wine isn't working on my Parrot OS

For the last few days, I’ve tried working installing Wine, Winetricks, PlayonLinux, and none of are working. I’ve tried enabling the 32bit architecture, etc. And yet, no matter what I do, I can’t get the program to work. Is there something that I’m doing wrong?

What version of Parrot are you running? Parrot 4.2.2, Sec, amd64

What method did you use to install Parrot? Debian GTK, I believe.

Configured to multiboot with other systems?.No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

hello i got wine work fine

do sudo then the architecture command i think wine should be pre-install

wine works for me too.
could you please be more specific so that we can reproduce the bug?

please try to run wine from terminal and give us the error message

also don’t forget to dist-upgrade your system

I managed to get everything working after I reinstalled parrot using the GTK installer from USB. Maybe something just went wrong in the process of installation. I’m still running tests to see if there’s anything else wrong with this installation.

At first Parrot wouldn’t allow me to install the 32bit arch for some reason. Essentially what had happened was that I tried to update, but the firewall at my school prevented certain things from being installed to my understanding. I went over to a friend’s house with open wifi and everything seems to be working so far. Reinstalling the dist seemed to fix the problem, but if this continues, i’ll update here.

I tried this but at the time, Parrot wouldn’t allow me to do this. I figured that it was my school’s firewall that prevented it.

└──╼ #wine
Usage: wine PROGRAM [ARGUMENTS…] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
└──╼ #