Wireguard-dkms error

I am facing issue when I run “sudo parrot-upgrade” command.
The error message are as follows:-

Building initial module for 5.2.0-2parrot1-amd64
Error! Bad return status for module build on kernel: 5.2.0-2parrot1-amd64 (x86_64)
Consult /var/lib/dkms/wireguard/0.0.20191012/build/make.log for more information.
dpkg: error processing package wireguard-dkms (--configure):
 installed wireguard-dkms package post-installation script subprocess returned error exit status 10
Setting up wireguard-tools (0.0.20191012-1) ...
dpkg: dependency problems prevent configuration of wireguard:
 wireguard depends on wireguard-dkms (= 0.0.20191012-1) | wireguard-modules (= 0.0.20191012); however:
  Package wireguard-dkms is not configured yet.
  Package wireguard-modules is not installed.

dpkg: error processing package wireguard (--configure):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.8.7-3) ...
Errors were encountered while processing:
Scanning application launchers

Updating active launchers
E: Sub-process /usr/bin/dpkg returned an error code (1)

And the make.log are attached please look into this.

I have tried “sudo dpkg --configure -a” but that would not help.

Please fix this bug/issue.

OS Release Information are as follows:-
No LSB modules are available.
Distributor ID: Parrot
Description: Parrot GNU/Linux 4.7
Release: 4.7
Codename: sid
Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Debian 5.2.9-2parrot1 (2019-08-25) x86_64 GNU/[make.log|attachment](upload://qLjJGEM8Xpz704yUKgmrNSwK24d.log) (2.2 KB)
1 Like

looks like unmet dependencies at a glance…

└──╼ #apt install wireguard-modules
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package wireguard-modules is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘wireguard-modules’ has no installation candidate

Can you tell me how to fix(Resolve dependency or point to the right package).

When I remove wireguard* package then no error came in build up with kernel module.
I think wireguard package have problem form developer side, so look into this when you have time.

I have this problem also :frowning:

I had a similar error message while updating:

Building module:
cleaning build area…
make -j4 KERNELRELEASE=5.4.0-1parrot1-amd64 -C /lib/modules/5.4.0-1parrot1-amd64/build M=/var/lib/dkms/wireguard/0.0.20191206/build…
.(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.4.0-1parrot1-amd64 (x86_64)
Consult /var/lib/dkms/wireguard/0.0.20191206/build/make.log for more information.

and the contents of var/lib/dkms/wireguard/0.0.20191206/build/make.log are:

DKMS make.log for wireguard-0.0.20191206 for kernel 5.4.0-1parrot1-amd64 (x86_64)
Wed 01 Jan 2020 01:03:42 AM MST
make: Entering directory ‘/usr/src/linux-headers-5.4.0-1parrot1-amd64’
AR /var/lib/dkms/wireguard/0.0.20191206/build/built-in.a
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/main.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/noise.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/device.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/peer.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/timers.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/queueing.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/send.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/receive.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/socket.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/peerlookup.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/allowedips.o
CC [M] /var/lib/dkms/wireguard/0.0.20191206/build/ratelimiter.o
/var/lib/dkms/wireguard/0.0.20191206/build/socket.c: In function ‘send6’:
/var/lib/dkms/wireguard/0.0.20191206/build/socket.c:145:20: error: ‘const struct ipv6_stub’ has no member named ‘ipv6_dst_lookup’; did you mean ‘ipv6_dst_lookup_flow’?
145 | ret = ipv6_stub->ipv6_dst_lookup(sock_net(sock), sock, &dst,
| ^~~~~~~~~~~~~~~
| ipv6_dst_lookup_flow
make[2]: *** [/usr/src/linux-headers-5.4.0-1parrot1-common/scripts/Makefile.build:271: /var/lib/dkms/wireguard/0.0.20191206/build/socket.o] Error 1
make[2]: *** Waiting for unfinished jobs…
make[1]: *** [/usr/src/linux-headers-5.4.0-1parrot1-common/Makefile:1665: /var/lib/dkms/wireguard/0.0.20191206/build] Error 2
make: *** [/usr/src/linux-headers-5.4.0-1parrot1-common/Makefile:179: sub-make] Error 2
make: Leaving directory ‘/usr/src/linux-headers-5.4.0-1parrot1-amd64’

I’ve just been booting into the older 5.3.9-3parrot3 kernel as I really haven’t had time
to mess with it.


So did you add the unstable repositories to the /etc/apt/sources.list to install wireguard?

If yes then you can run apt update && apt full-upgrade meanwhile if you face problem again and again then you have to run apt remove wireguard* after that you should run sudo parrot-update then every thing looks like fine.

Thanks for the response, much appreciated! No unstable repositories (too much trouble IMO),
but will keep your info handy if this is an ongoing problem.

Blame Palinuro for this. He updated latest version of kernel and wireguard wasn’t updated.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.