Xfce Synaptic Gui does not start on XFCE. * Workaround/Fix *

After updating the System and installation (sudo apt update && sudo apt install parrot-desktop-xfce) and change to XFCE, synaptic Gui does not start anymore.

On Vmware, Reproducible in Virtual Box

**Parrot version in use**
Home Edition 5.0 Electro Ara
VERSION="5.0 (Electro Ara)"

Logs/Terminal output

==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: user
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
Error executing command as another user: Not authorized  

Go to Menu → Settings Manager → Session and Startup → ApplicationAutostart. Scroll down and select → PolicyKit Authentication Agent ()
Restart or Log Out


1 Like

It’s because default startup of XFCE is sightly different. IDK much about this but when I created skel for XFCE, i enabled “gnome services and KDE service”.

Not sure why polkit didn’t start from your side but it’s starting by default on my side. Maybe it’s problem of skel

Hello dmknght. :slightly_smiling_face:

What is IDK and skel?

In my case “gnome services and KDE service” were already enabled.

I still disabled the “PolicyKit Authentication Agent” as described above and then restarted the machine with “gnome services and KDE service” enabled. But the synaptic gui did not start.

I reactivated the “PolicyKit Authentication Agent” as described above and then restarted the machine with “gnome services and KDE service” deactivated. The synaptic gui starts. :grinning:

Oh skel here means our pre-config for desktop environments and applications. Basically it’s configuration files / settings that changes default settings of apps / DEs and it’ll be our default settings.

From what I understand, these 2 options allows startup applications to enable applications of KDE / gnome. For example: gnome ssh agent, which allows you to use ssh keys. It doesn’t mean enable it == enable all startup applications. It more like “allow you to enable the other applications from other DE to start at boot”.
Let me check the skel again to see if this startup app was enabled in the setting
Update: yeah i didn’t enable any applications by default.