Parrot Community

Community portal of the Parrot Project.

You are not logged in.

Announcement

Welcome Aboard Pirate!

Support us on Patreon and contribute to our project!

HappyHacking!

#1 2017-05-17 07:14:20

Harry_Root
Community Member
Registered: 2017-05-17
Posts: 11

UNMET DEPENDENCIES in parrot 3.6

hi i have tried some of solutions from internet but of no vain.
Help me how to go about it.

$sudo apt-get clean
┌─[[email protected]]─[~]
└──╼ $sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  python3-advancedhttpserver python3-boltons python3-editor python3-geoip2
  python3-geojson python3-graphene python3-graphene-sqlalchemy
  python3-graphql-core python3-graphql-relay python3-icalendar python3-iso8601
  python3-mako python3-markupsafe python3-maxminddb python3-msgpack
  python3-pampy python3-paramiko python3-pluginbase python3-promise
  python3-psycopg2 python3-pyotp python3-singledispatch python3-sqlalchemy
  python3-termcolor python3-tzlocal python3-websocket python3-xlsxwriter
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  jsql-injection linux-headers-4.9.0-parrot25-amd64
  linux-headers-4.9.0-parrot25-common linux-image-4.9.0-parrot25-amd64
Suggested packages:
  linux-doc-4.9 debian-kernel-handbook
The following NEW packages will be installed:
  jsql-injection linux-headers-4.9.0-parrot25-amd64
  linux-headers-4.9.0-parrot25-common linux-image-4.9.0-parrot25-amd64
0 upgraded, 4 newly installed, 0 to remove and 2 not upgraded.
3 not fully installed or removed.
Need to get 47.6 MB of archives.
After this operation, 240 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http://ftp.cc.uoc.gr/mirrors/linux/parrot parrot/main amd64 linux-headers-4.9.0-parrot25-common all 4.9.25-1parrot25
  404  Not Found [IP: 147.52.159.12 80]
Err:2 http://ftp.cc.uoc.gr/mirrors/linux/parrot parrot/main amd64 linux-headers-4.9.0-parrot25-amd64 amd64 4.9.25-1parrot25
  404  Not Found [IP: 147.52.159.12 80]
Err:3 http://ftp.cc.uoc.gr/mirrors/linux/parrot parrot/main amd64 linux-image-4.9.0-parrot25-amd64 amd64 4.9.25-1parrot25
  404  Not Found [IP: 147.52.159.12 80]
Err:4 http://ftp.cc.uoc.gr/mirrors/linux/parrot parrot/main amd64 jsql-injection all 0.79-0kali2
  404  Not Found [IP: 147.52.159.12 80]
E: Failed to fetch http://ftp.cc.uoc.gr/mirrors/linux/parrot/pool/main/l/linux/linux-headers-4.9.0-parrot25-common_4.9.25-1parrot25_all.deb  404  Not Found [IP: 147.52.159.12 80]
E: Failed to fetch http://ftp.cc.uoc.gr/mirrors/linux/parrot/pool/main/l/linux/linux-headers-4.9.0-parrot25-amd64_4.9.25-1parrot25_amd64.deb  404  Not Found [IP: 147.52.159.12 80]
E: Failed to fetch http://ftp.cc.uoc.gr/mirrors/linux/parrot/pool/main/l/linux/linux-image-4.9.0-parrot25-amd64_4.9.25-1parrot25_amd64.deb  404  Not Found [IP: 147.52.159.12 80]
E: Failed to fetch http://ftp.cc.uoc.gr/mirrors/linux/parrot/pool/main/j/jsql/jsql-injection_0.79-0kali2_all.deb  404  Not Found [IP: 147.52.159.12 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Offline

#2 2017-05-17 12:40:14

vzz1x2
Community Member
From: Ireland
Registered: 2017-02-12
Posts: 168

Re: UNMET DEPENDENCIES in parrot 3.6

have you update first?

sudo apt-get update

Offline

#3 2017-05-19 03:46:03

Harry_Root
Community Member
Registered: 2017-05-17
Posts: 11

Re: UNMET DEPENDENCIES in parrot 3.6

vzz1x2 wrote:

have you update first?

sudo apt-get update


yes i updated. this is what i get after i run some of the commands:


┌─[[email protected]]─[~]
└──╼ $sudo apt-get upgrade
[sudo] password for harry:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
jsql : Depends: jsql-injection but it is not installed
linux-headers-amd64 : Depends: linux-headers-4.9.0-parrot25-amd64 but it is not installed
linux-image-amd64 : Depends: linux-image-4.9.0-parrot25-amd64 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
┌─[✗]─[[email protected]]─[~]
└──╼ $uname -a
Linux parrot 4.9.0-parrot18-amd64 #1 SMP Parrot 4.9.18-1parrot18 (2017-04-23) x86_64 GNU/Linux

Offline

#4 2017-05-19 06:08:23

Harry_Root
Community Member
Registered: 2017-05-17
Posts: 11

Re: UNMET DEPENDENCIES in parrot 3.6

ggwtfmate wrote:

Had the same problem earlier today with the same mirror. Seems like UoC mirror is down or whatever. What i did is i changed update mirror through synaptic and that way i could move on. (I used the italian mirrors).

i removed broken packages and now i dont get unmet dependencies error.
i think also that uoc mirror is down.  so what is the address for alternative mirrors?

Offline

Board footer

Powered by FluxBB

Design by Klocek.