Parrot Community

Community portal of the Parrot Project.

You are not logged in.

Announcement

Welcome Aboard Pirate!

Support us on Patreon and contribute to our project!

HappyHacking!

#1 2017-05-19 12:35:10

ayoub
Community Member
Registered: 2017-05-19
Posts: 8

how to fix this error

hi
i have parrot os last version in vmware but i have 3 problems:

1.when i want to start armitrage it give me terminal with error java 1360

(gksu:1255): Gtk-WARNING **: Theme directory devices/scalable of theme maia has no size field

A database appears to be already configured, skipping initialization
[* Initializing msfd...
[* Running msfd...
[* Starting msfrpcd for you.
[* MSGRPC starting on 127.0.0.1:55553 (NO SSL):Msg...

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: /build/glib2.0-vgyeXO/glib2.0-2.50.3/./gobject/gsignal.c:3492: signal name 'text_changed::delete' is invalid for instance '0x82027688' of type 'JawImpl_4098'

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

** (java:1360): CRITICAL **: atk_text_get_character_count: assertion 'ATK_IS_TEXT (text)' failed.

2.and when i want to scan ip it can't complet it give me

auxiliary failed : msf :: option validate error the following option failed to validate : rhost .

metasploit it work but armitrage not work

and when i write your code in terminal command it give me

ERROR: /usr/bin/msfdb: must be run as root

i do update in metasploit but not good result.

in parrot terminal when i want to install or write any thing it give me

E: could not open lock file .....

and

E: enable to lock adminitration derictory ...

more when start armitage it give a lot of

(java:1360): GLib-GObject-WARNING **: invalid cast from 'JawImpl_4098' to 'AtkText'

on metasploit famwork it give in terminal

fatal :not a git repository( or any of the parent derictories): .git

so where is the problem

Offline

#2 2017-05-19 22:23:48

CleanZombie
Community Member
Registered: 2017-05-06
Posts: 21

Re: how to fix this error

Its not a solution but have tried removing Metasploit and Armitage and then apt-get installing them again?

Offline

#3 2017-05-20 09:54:42

ayoub
Community Member
Registered: 2017-05-19
Posts: 8

Re: how to fix this error

it same metasploit and armitrage or i download other version ?

Offline

#4 2017-05-20 23:19:36

ayoub
Community Member
Registered: 2017-05-19
Posts: 8

Re: how to fix this error

when i want to remove metasploit it give me error
"E: Unable to locate package metasploit"
i thing it solve by sources.list ,but i can't paste or write any text in this list why
the sources.list it have this code:
#

# deb cdrom:[Debian GNU/Linux 3.0 _Parrot_ - Official Snapshot i386 LIVE/INSTALL Binary 20170307-06:13]/ parrot contrib main non-free

#deb cdrom:[Debian GNU/Linux 3.0 _Parrot_ - Official Snapshot i386 LIVE/INSTALL Binary 20170307-06:13]/ parrot contrib main non-free


so this is the problem or not ?

Offline

#5 2017-05-21 20:55:26

CleanZombie
Community Member
Registered: 2017-05-06
Posts: 21

Re: how to fix this error

thats fine as your sources.list file should be empty any ways but check  /etc/apt/sources.list.d/parrot.list
it should contain the following:

deb http://mirrordirector.archive.parrotsec.org/parrot stable main contrib non-free
#deb-src http://mirrordirector.archive.parrotsec.org/parrot stable main contrib non-free

Offline

#6 2017-05-22 13:59:54

ayoub
Community Member
Registered: 2017-05-19
Posts: 8

Re: how to fix this error

i can't copy or past or edit in sources.list why

Offline

#7 2017-05-22 15:02:54

CleanZombie
Community Member
Registered: 2017-05-06
Posts: 21

Re: how to fix this error

ayoub wrote:

i can't copy or past or edit in sources.list why

Probably because your sources.list file should be empty/unchanged, check the post I made earlier to see about changing sources in parrot ;)

Edit: make sure to check "show hidden files" in your file manager to find the correct sources list!

Last edited by CleanZombie (2017-05-22 15:03:59)

Offline

Board footer

Powered by FluxBB

Design by Klocek.