Parrot Community

Community portal of the Parrot Project.

You are not logged in.

Announcement

Welcome Aboard Pirate!

Support us on Patreon and contribute to our project!

HappyHacking!

#1 2017-10-17 20:50:17

palinuro
Parrot Project Founder
From: Italy
Registered: 2017-02-11
Posts: 238
Website

Parrot 3.9 - call for beta testers

The first Release Candidate images are ready to be downloaded by you.

Yes, you!

We did our best to prepare these preview images including all the updates and the new features introduced since the last release, but now we need your help to understand how to make it even better, and of course we need your help to understand if there is something that doesn’t work as expected or something that absolutely needs to be included in the final release.

Is the Release Candidate working and usable? Yes, and it was awesome for us to see how all these new updates developed separately were able to work merged together in the new version.

If you want to be helpful and contribute to the new release as a beta tester, all you have to do is to follow these steps:

    1) Browse our ISO archive (https://archive.parrotsec.org/parrot/iso/testing/).

    2) Download the ISO files you would like to test.

    3) Use the system as intensively as you can.

    4) Write a full report with your own experience, your suggestions and your bug reports as a comment to this topic.

    5) Send us your report within October 24 (the release day would probably be October 28).


NOTES:

Do NOT test the current version of Parrot (3.8)

To test the upgrade from a fresh install of parrot 3.8 to parrot 3.9 is not needed (we have already tested it, but if you want to have fun, do it anyway)

If you download the preview images and do not give us your feedback, your tests will be completely USELESS to us

We need you to test the testing images both in live and installed (your choice)


Lorenzo "Palinuro" Faletra - Parrot Security

GPG FINGERPRINT: B350 5059 3C2F 7656 40E6 DDDB 97CA A129 F4C6 B9A4
GPG Info: http://pgp.mit.edu/pks/lookup?op=vindex … 29F4C6B9A4
GPG Key: http://pgp.mit.edu/pks/lookup?op=get&se … 29F4C6B9A4

Offline

#2 2017-10-18 17:15:48

jblk01
Community Member
Registered: 2017-07-11
Posts: 7

Re: Parrot 3.9 - call for beta testers

Just booted a live session and I found that the redesigned menu on the lower left does not match that of the Applications menu in the upper right.

For example, the top Menu lists 5 programs under the 'Cryptography' header,  however none of these programs are listed under the header on the bottom menu.


menu_error.jpg

Offline

#3 2017-10-19 11:15:18

palinuro
Parrot Project Founder
From: Italy
Registered: 2017-02-11
Posts: 238
Website

Re: Parrot 3.9 - call for beta testers

jblk01 wrote:

Just booted a live session and I found that the redesigned menu on the lower left does not match that of the Applications menu in the upper right.

For example, the top Menu lists 5 programs under the 'Cryptography' header,  however none of these programs are listed under the header on the bottom menu.


https://s1.postimg.org/2vvzowgntn/menu_error.jpg


i can confirm the menu bug

the menu files are properly configured and the submenu follows the standards

as you can notice, it is not a problem caused by the addition of a dedicated new menu as the anonsurf menu works perfectly

the only difference between the anonsurf menu and the cryptography menu is that the latter is replicated in the first level of menus and as a section of the parrot menu

i tried to remove the section from the parrot menu and the problem was fixed, if you agree i can make this change permanent and fix the problem


Lorenzo "Palinuro" Faletra - Parrot Security

GPG FINGERPRINT: B350 5059 3C2F 7656 40E6 DDDB 97CA A129 F4C6 B9A4
GPG Info: http://pgp.mit.edu/pks/lookup?op=vindex … 29F4C6B9A4
GPG Key: http://pgp.mit.edu/pks/lookup?op=get&se … 29F4C6B9A4

Offline

#4 2017-10-19 18:25:11

PC_Mechanic
Community Member
Registered: 2017-04-29
Posts: 12

Re: Parrot 3.9 - call for beta testers

As mentioned in my post on Facebook here are a couple issues I've noticed

Bumblebee installation doesnt work as before (installed exactly as documented on the parrot website)

The driver seems to load and bumblebee service runs but using optirun i get the following error

sudo optirun glxgears -info
[ 1153.661504] [ERROR]No bridge found. Try installing primus or virtualgl.

Installing Primus also throws an error message,

sudo optirun --bridge primus glxgears -info

primus: fatal: failed to load any of the libraries: /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1:/usr/lib/i386-linux-gnu/nvidia/libGL.so.1:/usr/lib/nvidia/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/i386-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory

Offline

#5 2017-10-19 18:31:00

PC_Mechanic
Community Member
Registered: 2017-04-29
Posts: 12

Re: Parrot 3.9 - call for beta testers

Virtualbox wont install - require a higher version of python

sudo apt-get install virtualbox

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualbox : Depends: python3 (>= 3.6~) but 3.5.3-3 is to be installed
              Recommends: virtualbox-qt (= 5.1.30-dfsg-1) but it is not going to be installed

Offline

#6 2017-10-22 01:27:04

palinuro
Parrot Project Founder
From: Italy
Registered: 2017-02-11
Posts: 238
Website

Re: Parrot 3.9 - call for beta testers

PC_Mechanic wrote:

As mentioned in my post on Facebook here are a couple issues I've noticed

Bumblebee installation doesnt work as before (installed exactly as documented on the parrot website)

The driver seems to load and bumblebee service runs but using optirun i get the following error

sudo optirun glxgears -info
[ 1153.661504] [ERROR]No bridge found. Try installing primus or virtualgl.

Installing Primus also throws an error message,

sudo optirun --bridge primus glxgears -info

primus: fatal: failed to load any of the libraries: /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1:/usr/lib/i386-linux-gnu/nvidia/libGL.so.1:/usr/lib/nvidia/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/i386-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory

then you have to install the proper libgl provider

remember that it is caused by some debian unresolved bugs due to the release of the new mesa 17 in debian testing

here some reference bugs i have found
https://bugs.debian.org/cgi-bin/bugrepo … bug=876766
https://bugs.debian.org/cgi-bin/bugrepo … bug=875438

this is not a problem for the release of parrot 3.9 as it will not include proprietary nvidia drivers, but we are monitoring it and waiting for a debian response


Lorenzo "Palinuro" Faletra - Parrot Security

GPG FINGERPRINT: B350 5059 3C2F 7656 40E6 DDDB 97CA A129 F4C6 B9A4
GPG Info: http://pgp.mit.edu/pks/lookup?op=vindex … 29F4C6B9A4
GPG Key: http://pgp.mit.edu/pks/lookup?op=get&se … 29F4C6B9A4

Offline

#7 2017-10-22 01:30:47

palinuro
Parrot Project Founder
From: Italy
Registered: 2017-02-11
Posts: 238
Website

Re: Parrot 3.9 - call for beta testers

PC_Mechanic wrote:

Virtualbox wont install - require a higher version of python

sudo apt-get install virtualbox

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualbox : Depends: python3 (>= 3.6~) but 3.5.3-3 is to be installed
              Recommends: virtualbox-qt (= 5.1.30-dfsg-1) but it is not going to be installed

this is a debian deendency problem that will be fixed very soon, i have not searched for a debian bug related to this issue but i'm sure it's there and it wil be fixed very soon as python 3.6 has recently entered debian testing and we are already monitoring its transit

anyways virtualbox is not part of the release of parrot 3.9 and we already ship a virtual machine manager based on KVM which is probably the most powerful hypervisor out there


Lorenzo "Palinuro" Faletra - Parrot Security

GPG FINGERPRINT: B350 5059 3C2F 7656 40E6 DDDB 97CA A129 F4C6 B9A4
GPG Info: http://pgp.mit.edu/pks/lookup?op=vindex … 29F4C6B9A4
GPG Key: http://pgp.mit.edu/pks/lookup?op=get&se … 29F4C6B9A4

Offline

#8 2017-10-29 22:15:49

oldman
Unconfirmed Member
Registered: 2017-10-29
Posts: 1

Re: Parrot 3.9 - call for beta testers

Hi everyone,

I unintentionally  became  a beta tester :-D I've upgraded my virtual parrot running on physical Windows 10 machine in Virtual Box as usual and new version Intruder 3.9 popped up.

─[✗]─[[email protected]]─[~]
└──╼ $uname -a
Linux parrot 4.9.0-parrot13-amd64 #1 SMP Parrot 4.9.13-1parrot1 (2017-03-02) x86_64 GNU/Linux

┌─[[email protected]]─[~]
└──╼ $lsb_release -a
No LSB modules are available.
Distributor ID: Parrot
Description:    Parrot 3.9 - Intruder
Release:    3.9
Codename:   intruder

┌─[[email protected]]─[~]
└──╼ $cat /etc/*-release
DISTRIB_ID=Parrot
DISTRIB_RELEASE=3.9
DISTRIB_CODENAME=intruder
DISTRIB_DESCRIPTION="Parrot 3.9 - Intruder"
PRETTY_NAME="Parrot GNU/Linux 3.9 Intruder"
NAME="Parrot GNU/Linux"
ID=parrot
VERSION="3.9 (Intruder)"
VERSION_ID="3.9"
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="https://www.parrotsec.org/"
SUPPORT_URL="https://community.parrotsec.org/"
BUG_REPORT_URL="https://dev.parrotsec.org/"

Main bug/issue for me at this moment is that my shared windows / virtual box directory has disappeared from virtual Parrot OS.
Shared directory still sits in /media/ and it is accessible but it's empty. I need to be able to transferr files between win and parrot and I'm not.

Would anyone be able to have a look into it please?

It made me wonder, is it a good idea to deploy new versions straight into  the main repo what quite a few people use I can imagine? Wouldn’t it be better if you had some testing/beta repo for this and once you're satisfied with results of testing then merge changes to main repo?

Cheers

Mike

Offline

#9 2017-10-31 17:48:52

thor
Community Member
Registered: 2017-07-22
Posts: 5

Re: Parrot 3.9 - call for beta testers

I have the same problem with virtualbox.
I did not find any bag on debian 9
If you can not fix the problem, how can I downgrade to stable version.
Thanks

Ciao Palinuro, ho lo stesso problema con virtualbox.
Ho cercato il problema su debian 9 ma non sembra esistere.
Se non potete fixare questo problema, vorrei sapere se fosse possibile downgradare alla versione stabile e tornare indietro.
Purtroppo ho aggiornato la distribuzione senza accorgermi che era una beta
Grazie
Ciao

Offline

#10 2017-10-31 17:59:44

thor
Community Member
Registered: 2017-07-22
Posts: 5

Re: Parrot 3.9 - call for beta testers

Also there are also problems with the burpsuite plugins for all plugins that use python (jinton) and I'm also having problems with firefox

Thanks

Inoltre ho notato che ci sono problemi anche con tutti i plugin di burpsuite che utilizzano python (jinton), non vengono caricati e vanno in errore

Sto avendo anche problemi su firefox mi ha cancellato tutti i preferiti non so se dipende dall'aggiornamento alla 3.9
Grazie
Ciao

Offline

#11 2017-11-04 22:42:36

palinuro
Parrot Project Founder
From: Italy
Registered: 2017-02-11
Posts: 238
Website

Re: Parrot 3.9 - call for beta testers

p.s. parrot is based on debian 10, not debian 9


anyways if the virtual machine compatibility does not work properly, then you should try to re-install the guest additions


Lorenzo "Palinuro" Faletra - Parrot Security

GPG FINGERPRINT: B350 5059 3C2F 7656 40E6 DDDB 97CA A129 F4C6 B9A4
GPG Info: http://pgp.mit.edu/pks/lookup?op=vindex … 29F4C6B9A4
GPG Key: http://pgp.mit.edu/pks/lookup?op=get&se … 29F4C6B9A4

Offline

#12 2017-11-08 14:00:16

fohkis
Unconfirmed Member
Registered: 2017-11-08
Posts: 1

Re: Parrot 3.9 - call for beta testers

Chrome installation does not work. It installs completely, but does not run.

Offline

#13 2017-11-15 12:34:28

thor
Community Member
Registered: 2017-07-22
Posts: 5

Re: Parrot 3.9 - call for beta testers

The virtualbox installation is now ok.

Thanks Palinuro

Offline

#14 2017-11-15 17:13:27

thor
Community Member
Registered: 2017-07-22
Posts: 5

Re: Parrot 3.9 - call for beta testers

not work installation w3af

sudo apt install w3af-console
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
w3af-console : Depends: mitmproxy (>= 0.17) but it is not going to be installed
                Depends: python-guess-language but it is not installable
                Depends: python-xdot but it is not installable
E: Unable to correct problems, you have held broken packages.

Offline

#15 2017-11-15 17:15:27

thor
Community Member
Registered: 2017-07-22
Posts: 5

Re: Parrot 3.9 - call for beta testers

Not work installation mitmproxy

sudo apt install mitmproxy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mitmproxy : Depends: python-hyperframe (< 5) but 5.1.0-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Offline

Board footer

Powered by FluxBB

Design by Klocek.