502 Bad Gateway Errors when using apt

Kia ora,

I’m getting a bunch of 502 errors whenever I try to install or do anything using apt.

I’ve also tried a north american mirror to no avail.

Anyone else experiencing similar or know whats up?

  • **Parrot version in use
    └──╼$cat /etc/os-release | grep VERSION
    VERSION=“5.0 (LTS)”

└──╼ $uname -r

└──╼ $apt --version
apt 2.2.4 (amd64)

  • Logs/Terminal output (use pastebin or similar services):

Error example


  • Screenshots:

Yep, same here… I don’t ahve time now, I’ll try some other mirrors later today. Did you get it sorted?

Did either of you manage to resolve this? I’ve been having this issue ever since upgrading to 5.0 :confused:

I too have been getting Timeouts and 504 errors. It seems for me it’s the edge1 mirror, but also the main parrot mirror too sometimes.

What I had to do was change out the mirror list for a known working mirror. Here are the error types I’ve been getting when trying to upgrade or install stuff:

Err:75 https://edge1.parrot.run/parrot rolling/main amd64 codium amd64 1.64.2-1644538525
Connection timed out [IP: 443]

Err:57 https://edge1.parrot.run/parrot rolling/main amd64 python3-javaproperties all 0.7.0-1
504  Gateway Timeout [IP: 443]

Err:3 https://edge1.parrot.run/parrot rolling/main amd64 slirp4netns amd64 1.0.1-2
504  Gateway Timeout [IP: 443]
Fetched 97.0 MB in 16s (5,957 kB/s)                                        
E: Failed to fetch https://edge1.parrot.run/parrot/pool/main/s/slirp4netns/slirp4netns_1.0.1-2_amd64.deb  504  Gateway Timeout [IP: 443]


Should’ve come back to this actually, I fixed the problem yesterday by adding the JP mirror to my sources list in /etc/apt/sources.list.d/ and it fixed it. There’s a ParrotOS guide here to update your sources list to use a mirror near you if you’re having this issue. Hoping they fix whatever’s up with the parrot and edge1 mirrors soon though.

Hey, yeah I had to use another mirror. Seems most of the edge mirrors are toast for now. I’m currently using the following mirror without any issues:

1 Gbps	



deb http://mirrors.mit.edu/parrot/ parrot main contrib non-free

So the MIT hosted mirror works great. I also have used the Leaseweb mirror in Europe without issues as well, the halifax one, for anyone in Europe.

If anyone would like to see my parrot.list let me know.