ACPI errors with HP pavilion gaming cx0026nl

PROBLEM: Hi, I have a problem while booting parrot os in dual boot with windows: I’ve got an hp pavilion gaming laptop with two hard drives: the first is an nvme with windows, and the second is a normal sata hdd used for data, and I wanted to partition it in order to boot parrot on it. The model is this one:

If I follow the common installation the operating system boots only in tty mode, and after 15 seconds it just shut down automatically, (I got a picture of the errors while booting in this mode).

I tried also with acpi off, and it boots “normally”, but I can’t use the touchpad in 4.7, and both in 4.7 and 4.8 I can’t use the wifi card, I can’t shut down my pc (it freeze while shutting down, and I must use the power button). I also tried with the acpi strict mode, but I got again the errors in the picture, and I obtained again the tty mode (if I try to switch to the desktop mode, it just do nothing).
I already tried to contact hp support on social, on the phone, and on the community, but all thew told me was “we only can help if the problem is with windows, we don’t offer support for linux”… Thank you for the help!!!

Parrot-security-4.7_x64 (mate desktop)
Parrot-security-4.8_x64 (mate desktop)

METHOD:debian standard

MULTIBOOT: yes, with windows.

SIMILAR ISSUES: Yes, but i’ve already tried all the classical solution: connect an ethernet and try an update-upgrade, tried every combination of security boot or legacy, already tried acpi strict and acpi off, but nothing worked: sometimes nothing changes, sometimes I got a kernel panic

ERROR MESSGE: see the photo.

Other things: maybe I could have an error while reading the wifi card, the realtek rtl822be, but I can’t understand if this could be the error or not

Welcome to the ParrotOS Community :hugs:
this seem similar to
ACPI BIOS Error (bug)
which seems still under discussion to report it or not until then there is not much you can probably do about.

Thank you for your immediate answer!! I’ll continue to watch that discussion to see if they maybe find a soluzion, and I apologize because I know this post may seems similar to other ACPI posts, but i decided to post it aniway because I already followed every possible solution from september until now but nothing didn’t work … If I should give up with linux (i tried other 5 distros), I just want to know if it’s a linux kernel problem and I just need to wait, or an HP problem, and I should continue calling them in order to find a solution.
Thank you very much again :wink:

No Problem :smiley: ,Hope there’s a Solution soon

1 Like

I tried again with Ubuntu, but simply doesn’t start: the live shuts down immediately. Parrot OS is the only one that actually “boots”, but with the problem mentioned in the post.
After 6 months, a guy in HP assistance told me something about a “second level of assistance”, and he will tell me what they will say. I’ll tell you what could be as soon as he calls me. (probably monday or tuesday). Maybe if he finds something, I hope that those informations could be useful for other users

Hope that information Helps :smiley:

1 Like

I followed two mail of instructions that HP sent me, but no one of them worked (I already tried with both GPT and MBR partition scheme). They told me that if no one worked, probably my laptop will never work with linux because of its BIOS. Anyway, I’ve just sent them the error, and I still hope there could still be a solution … every answere will be reported under this post.
Anyway I’ll copy the link they sent me, even if those link explained stuff that I already tried, hoping that those links could be helpful for someone:
In the first mail they told me to:

In the second mail they told me to:

I tried, for both the links:

  • Parrotsec
  • Ubuntu
  • Mint

but unfortunately no one work :sleepy:
I hope anyway that these instruction could be helpful for someone
I want to say thanks to Stefano of the italian HP assistance, that finally, after six months, helped me (other people at HP assistance were just saying the same sentences like a “robot”, without being helpful)

Sorry but we cannot do anything about the Bios :slightly_frowning_face:

1 Like

Yes, I know I know, and this is not a Parrot problem :muscle: just reporting what they are saying to me, in order to save some time to people that may have my problem, because this answer by HP took me 6 months :joy: (I want anyway to say a BIG thanks to this community for trying to help me !!:muscle:)
If HP will tell me that there is nothing I can do, I think I’ll save some money in order to by some used PC or stuff like that (I apologize, but I don’t know the exact English translation of what I call “used PC”), in order to have a complete system with Parrotsec

1 Like

You should try a BIOS update, that is the only thing that can actually solve ACPI table issues, that is what you have. All the machines I use linux on have these errors but none that make installation or operation impossible, indeed there are actually a lot of bugged ACPI implementations.
Also HP gives you not great advice, Rufus was designed to work with Windows and doesn’t work right with hybrid iso files(most distros use hybrid iso format by default for a while now). Use Etcher, fast, simple, cross-platform;

1 Like

Yes, I check BIOS update before every installation, and it is up to date. I asked HP if they could make an update to fix this problem, and what they told me was that “they probably will never release an update to fix this thing, because my laptop didn’t came out with linux pre-installed, and because of this, the BIOS has no bad implementation in their opinion, and there is no reason to make my pc work with linux” :disappointed_relieved:.
Thank you for the etcher suggestion, in these days I need to study a little bit for university, but probably monday or tuesday I’ll try an installation with it :grinning:

Ok I got the LAST answer: I sent them also the photo of the installation and of the errors, they talked with their superiors, and what HP told me was that I’ve done the installation correctly, but if I’ve got those error, it means that my bios doesn’t support dual boot with linux :neutral_face:
The best solution in their opinion is to keep parrot in dual boot since it’s the one that goes further down the installation and actually boot in some way, and since it freeze while shutting down, and since this is not a parrot problem but a bios proble, when I use linux I should turn it off using the power button … I want an advice: they told me that this could maybe one day ruin my disk or the partition, but it should work generally fine and this should not ruin my laptop, and this is the solution that they would use … is it safe to turn down every time my pc while using linux, using the power button?

Hello landomix,

I have an HP Omen that I have had a heck of a time, similar to yours, getting past the errors you are showing. I am not sure if you have tried switching to legacy boot.

Prior to simply switching to legacy boot I tired all sorts of combos with nomodeset, acpi=off, etc. A few got me close.

Last night I enjoyed some amazing kush of sorts when I decided to switch to legacy boot. Installed with no problems and booted right up. No nomodeset, acpi=off, etc. Just loads right up.

I apologise if my response does not help. Have a great day!

1 Like

its because of nvidia drivers


Hi, yes, unfortunately I already tried that solution, with legacy boot but didn’t worked … Thank you anyway for your help !! :smiley:

I tried to solve this with bumblebee but unfortunately didn’t worked :disappointed_relieved:
Is there any other solution for this? (even if I think that all those error are not thrown only because of nvidia driver, I think there is something more, because I got many kernel panic, and many problems while loading lives of many others linux distro)

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.