Add Firmware & Driver For QCA9337

I am running Parrot Security 4.3 but also used previous versions but there is a lack of firmware for Qualcomm Atheros QCA9337 Wireless Adapter. For this the Wireless Adapter cannot enter into the monitor mode or in the promiscous mode & for this I can’t perform any wireless penetration test through it.
running the ‘dmesg’ command as a root user I have came to know that the missing firmware and driver related issues are given below. I also suggest you to add all third party or non-free firmware for all wireless adapters. Then it will be the best OS ever.

[   14.806015] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
[   14.806019] firmware_class: See for information about missing firmware
[   14.806040] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
[   14.806065] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-6.bin (-2)
[   15.072773] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[   15.072786] ath10k_pci 0000:03:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 1a3b:2231
[   15.072789] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[   15.073318] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[   15.276928] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[   15.277152] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a

Unfortunately we don’t necessarily have control over the ones that are supported (further narrowing that list are ones that actually support packet injection AKA monitor mode) as they require to be supported by the current kernel etc. That being said I believe I have this same driver loaded and it does support it but mine is missing half of the pigtail connection and as it’s inbuilt to the MOBO has to be ordered so I don’t use that interface anymore but I want to say it automatically was able to be recognized until I deleted or disabled it in windows and then I always got that error on boot regardless of what I did but it still worked

Add backports project for wireless adapters

@palinuro said that firmware for QCA9337 has been added into the Parrot Security 4.5.1 but still it’s not working, it’s not my adapter failure. I have tried others PC where there is QCA9377 is internal adapter like me. Qualcomm said that this chipset supports packet injection. But because of the lack of firmware files the monitor mode not working.

1 Like