AMD driver issues after update 27/Sep/21

Just upgraded Parrot, lost all display resolution choices but 1024768. Standard screen resolution is 19201080 and worked fine on last boot about 2 days ago. firmware-amd package says it’s the latest version, so does xserver-xorg-video-amdgpu. I’ve done about 2 hours of Googling, tried some resolution forcing via xrandr, but I haven’t gotten anywhere, and it’s driving me nuts. Any suggestions would be much appreciated!

Parrot version 4.11

Kernel version 5.14.0-2parrot1-amd64

Exact same issue. It seems like this is not a specific vendor issue. This is an issue that affects both AMD/Nvidia cards, laptop baby-cards, everything.

Tried re-installing ‘amdgpu’ drivers from AMD website, using amdgpu/pro-uninstall then reinstall. Both as root/user.

Sigh… this looks like a major issue across all sorts of different hardware since update. I tried rolling back kernels but the issue was persistent.

Need a fix or an update asap. Begs the question of prerelease testing on various hardware.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.