AnonSurf- Connection issues

networking
(mike) #1

Briefly describe your issue below:
After a reboot, I must enbale and disable Anonsurf to regain internet. I am able to connect to various wifi connections but none give me internet until i enable/disable. This issue started since using Anonsurf for the first time.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Fress install of 4.6 updated using parrot-upgrade

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard on bootable usb
Configured to multiboot with other systems? (yes / no)
Yes, Windows 10
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
I get this error after I disable Anonsurf

\ * Restarting services
Failed to start dnsmasq.service: Unit dnsmasq.service not found.
Failed to start nscd.service: Unit nscd.service not found.

  • It is safe to not worry for dnsmasq and nscd start errors if they are not installed or started already.
  • Anonymous mode stopped

I did get a “resolv.conf not found” error that occasionaly pops up during this process

(Matt) #2

Make sure you run

sudo anonsurf stop

when you are finished using anonsurf and before you shutdown your computer.

1 Like
(dmknght) #3

when you enable, anonsurf changes your DNS settings to its settings. If you don’t run anonsurf stop, your old DNS settings won’t be backed up. It is a known issues. We have some idea about this but we can’t test atm.

1 Like