Anonsurf

Briefly describe your issue below:
Hi guys, i know that there is a lot of topics on this community about anonsurf that doesn’t work, i already tried everything that i have read but i can’t solve this problem. My connection works fine, once a start anonsurf the connection doesn’t work anymore. I tried with ‘‘sudo cp /etc/anonsurf/torrc /etc/tor/torrc && service tor restart’’ but nothing have changed, the system time is fine, i already upgrade the system with sudo dist-upgrade. I don’t actually know what i can do to fix it, i already tried my best.

What version of Parrot are you running? (include version, edition, and architecture)
Release 4.2 64-bit
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)
no
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

hi omer where are you from??

@Anubi5egypt want to point , that you are probably living in a country where TOR is blocked
Try out his:

2 Likes

@g0rbe can you make video for this

I’m Italian but i live in Australia. Anonsurf worked fine till 4 weeks ago but i don’t actually know what happened, it’s suddendly stopped working and i can’t fix it. I just noticed that Tor give me this warn
“[warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?”. Could it be another process running? The thing is that i don’t actually know which other program could use tor, i don even have tor broswer installed.

Actually more than one :fearful:
Aug 21 10:01:59.008 [notice] Tor 0.3.3.9 (git-ca1a436fa8e53a32) running on Linux with Libevent 2.1.8-stable, OpenSSL 1.1.0h, Zlib 1.2.11, Liblzma 5.2.2, and Libzstd 1.3.4.
Aug 21 10:01:59.008 [notice] Tor can’t help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Aug 21 10:01:59.008 [notice] Read configuration file “/etc/tor/torrc”.
Aug 21 10:01:59.012 [notice] Scheduler type KIST has been enabled.
Aug 21 10:01:59.012 [notice] Opening Socks listener on 127.0.0.1:9050
Aug 21 10:01:59.012 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Aug 21 10:01:59.012 [notice] Opening DNS listener on 127.0.0.1:53
Aug 21 10:01:59.012 [notice] Opening Transparent pf/netfilter listener on 127.0.0.1:9040
Aug 21 10:01:59.012 [warn] Could not bind to 127.0.0.1:9040: Address already in use. Is Tor already running?
Aug 21 10:01:59.012 [notice] Opening Control listener on 127.0.0.1:9051
Aug 21 10:01:59.012 [warn] Could not bind to 127.0.0.1:9051: Address already in use. Is Tor already running?
Aug 21 10:01:59.012 [notice] Closing partially-constructed DNS listener on 127.0.0.1:53
Aug 21 10:01:59.012 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Aug 21 10:01:59.012 [err] Reading config failed–see warnings above.

Just edit some lines, it is not worth a video

Make sure that tor not running: sudo service status tor
If you see those errors too, check what is running on those ports: netstat -putanl
The problem is that something uses those ports

dist-upgrade the system and retry, there are some important updates in the anonsurf and tor packages

Sorry i have been busy these days. i did the dist-upgrade, but my ip remain the same. when i start anonsurf it says that the iptables can’t be found.

Gtk-Message: 18:35:31.867: GtkDialog mapped without a transient parent. This is discouraged.
[] killing dangerous applications
[
] Dangerous applications killed
[] cleaning some dangerous cache elements
[
] Cache cleaned

[ i ] Starting anonymous mode:

  • Tor is not running! starting it for you

  • Stopping service nscd (already stopped)

  • Stopping service resolvconf (already stopped)

  • Stopping service dnsmasq (already stopped)
    /usr/bin/anonsurf: line 123: iptables-save: command not found

  • Saved iptables rules

/usr/bin/anonsurf: line 127: iptables: command not found
/usr/bin/anonsurf: line 128: iptables: command not found

  • Modified resolv.conf to use Tor and ParrotDNS/OpenNIC

  • Disabling IPv6 for security reasons

/usr/bin/anonsurf: line 137: sysctl: command not found
/usr/bin/anonsurf: line 138: sysctl: command not found

  • Configuring iptables rules to route all traffic through tor

/usr/bin/anonsurf: line 142: iptables: command not found

  • Redirecting DNS traffic through tor

/usr/bin/anonsurf: line 146: iptables: command not found
/usr/bin/anonsurf: line 147: iptables: command not found
/usr/bin/anonsurf: line 148: iptables: command not found
/usr/bin/anonsurf: line 151: iptables: command not found
/usr/bin/anonsurf: line 152: iptables: command not found
/usr/bin/anonsurf: line 156: iptables: command not found
/usr/bin/anonsurf: line 157: iptables: command not found
/usr/bin/anonsurf: line 156: iptables: command not found
/usr/bin/anonsurf: line 157: iptables: command not found
/usr/bin/anonsurf: line 156: iptables: command not found
/usr/bin/anonsurf: line 157: iptables: command not found
/usr/bin/anonsurf: line 156: iptables: command not found
/usr/bin/anonsurf: line 157: iptables: command not found
/usr/bin/anonsurf: line 156: iptables: command not found
/usr/bin/anonsurf: line 157: iptables: command not found
/usr/bin/anonsurf: line 161: iptables: command not found
/usr/bin/anonsurf: line 162: iptables: command not found
/usr/bin/anonsurf: line 163: iptables: command not found
/usr/bin/anonsurf: line 166: iptables: command not found

  • Allowing only tor to browse in clearnet

/usr/bin/anonsurf: line 170: iptables: command not found
/usr/bin/anonsurf: line 171: iptables: command not found

  • All traffic was redirected throught Tor

[ i ] You are under AnonSurf tunnel

wow, what did you do???
The paroblem is, that you dont have iptables installed
install it with sudo apt install iptables

your system looks like it’s damaged or not an original Parrot installation, could you please tell us what you did to the system to remove 2 of the most important system components?

and no, the standard parrot dist-upgrades do not remove iptables and sysctl, so the problem was not with the system upgrade, but it is caused by other actions you did

I downloaded it from the Parrot sec website 1 year ago, i never deleted anything. But now i’m thinking that this problem appeared after installing and uninstalling, after 2 weeks, 4nonimizer. i purged it… could be that the problem? i know how important are the ip tables but these errors appeared after doing the dist-upgrade anyway. Before it didn’t mention anything like that

Well, i just tried to install the ip tables and it says:

$sudo apt install iptables
Reading package lists… Done
Building dependency tree
Reading state information… Done
iptables is already the newest version (1.6.2-1.1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

and anonsurf keep giving me the same problem.

i don’t know 4nonymizer, but of course it is not an official parrot tool, and if it modifies the operating system, then you spotted the cause of your specific issue

if you can’t recover the system properly, consider re-installing it, maybe by trying the new 4.2 release

when are going to release the 4.2? that’s probably the best thing to do

you can already download the beta images from the beta testing program topic - development section

Hey i hate that popup when start anonsurf do you want anonsurf to kill dangerous application i want to not popup just hit yes automatic is that possible

You can do it if you modify the script.

sudo nano /usr/bin/anonsurf
then
CTRL + SHIFT + - type 276 then hit enter. (Go to line number)
It should be on a line that starts with ‘zenity’, in the first case of a switch statement.
Remove all of that line with the exception of ‘init’ at the end. It should look like this:

start)
      init
      start
;;

You could also do it for the ‘stop’ case below, if you dont want it to popup when you stop anonsurf.
CTRL + S to save then CTRL + X to quit

Hi,

same problem here with surface 4 and parrot home.
All works fine atm … only anonsurf sucks.

same errors like Osmar_Romeo.

iptables are install. but it seams that the script sucks with low priviliges maybe ?
new install without any update - doesnt work
no changes … only set kb layout to german.

now i will try a dist-upgrade